Skip to content

← Actionable
Low, CVSS 3.7amended

h3: Missing Path Segment Boundary Check in mount() Causes Middleware Execution on Unrelated Prefix-Matching Routes

CVE-2026-33490GHSA-2j6q-whv2-gh6w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (h3 2.0.1-rc.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm h3

    Affected
    >= 2.0.1-alpha.0, <= 2.0.1-rc.16
    Fixed in
    2.0.1-rc.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-33490: 0.25% estimated exploitation activity in the next 30 days; percentile 16.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The mount() method in h3 uses a simple startsWith() check to determine whether incoming requests fall under a mounted sub-application's path prefix. Because this check does not verify a path segment boundary (i.e., that the next character after the base is / or end-of-string), middleware registered on a mount like /admin will also execute for unrelated routes such as /admin-public, /administrator, or /adminstuff. This allows an attacker to trigger context-setting middleware on paths it was never intended to cover, potentially polluting request context with unintended privilege flags. Details The root cause is in src/h3.ts:127 within the mount() method: When a sub-app is mounted at /admin, the check originalPathname.startsWith("/admin") returns true for /admin, /admin/, /admin/dashboard, but also for /admin-public, /administrator, /adminFoo, etc. The mounted sub-app's entire middleware chain then executes for these unrelated paths. A secondary instance of the same flaw exists…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2j6q-whv2-gh6w

  2. Revision 1 · created ·

    Published from osv record GHSA-2j6q-whv2-gh6w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33490

Advisory: h3: Missing Path Segment Boundary Check in `mount()` Causes Middleware Execution on Unrelated Prefix-Matching Routes
IDs: CVE-2026-33490, GHSA-2j6q-whv2-gh6w
Record: https://patchnext.com/advisories/cve-2026-33490 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: h3 2.0.1-rc.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm h3: affected >= 2.0.1-alpha.0, <= 2.0.1-rc.16; fixed in 2.0.1-rc.17

## Suggested inspection (read-only)
- `npm ls h3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on h3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2j6q-whv2-gh6w (OSV record GHSA-2j6q-whv2-gh6w lists affected ranges: npm h3 >=2.0.1-alpha.0 <2.0.1-rc.17 (fixed))
- Verified: https://github.com/advisories/GHSA-2j6q-whv2-gh6w (GitHub-reviewed advisory GHSA-2j6q-whv2-gh6w lists affected ranges: npm h3 >=2.0.1-alpha.0 <=2.0.1-rc.16)

Commands are suggestions: review each one before running it.

Loading voting…