langflow has Unauthenticated IDOR on Image Downloads
CVE-2026-33484GHSA-7grx-3xcx-2xv5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow
- Affected
- >= 1.0.0, < 1.9.0
- Fixed in
- 1.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7grx-3xcx-2xv5 lists affected ranges: PyPI langflow >=1.0.0 <1.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7grx-3xcx-2xv5 lists affected ranges: PyPI langflow >=1.0.0 <1.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-33484: 5.94% estimated exploitation activity in the next 30 days; percentile 93.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The /api/v1/files/images/{flowid}/{filename} endpoint serves image files without any authentication or ownership check. Any unauthenticated request with a known flowid and filename returns the image with HTTP 200. Details src/backend/base/langflow/api/v1/files.py:138-164 — downloadimage takes flowid: UUID as a bare path parameter with no Depends(getflow) or CurrentActiveUser. All other file routes (downloadfile, uploadfile, listfiles, deletefile) use Depends(getflow) which enforces both authentication and ownership. There is no global auth middleware on /api/v1; protection is per-endpoint only. PoC Impact Unauthenticated cross-tenant data leak. In a multi-tenant deployment, any attacker who can discover or guess a flowid (UUIDs can be leaked through other API responses) can download any user's uploaded images without credentials.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7grx-3xcx-2xv5
- Revision 1 · created ·
Published from osv record GHSA-7grx-3xcx-2xv5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33484 Advisory: langflow has Unauthenticated IDOR on Image Downloads IDs: CVE-2026-33484, GHSA-7grx-3xcx-2xv5 Record: https://patchnext.com/advisories/cve-2026-33484 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langflow 1.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow: affected >= 1.0.0, < 1.9.0; fixed in 1.9.0 ## Suggested inspection (read-only) - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7grx-3xcx-2xv5 (OSV record GHSA-7grx-3xcx-2xv5 lists affected ranges: PyPI langflow >=1.0.0 <1.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7grx-3xcx-2xv5 (GitHub-reviewed advisory GHSA-7grx-3xcx-2xv5 lists affected ranges: PyPI langflow >=1.0.0 <1.9.0) Commands are suggestions: review each one before running it.
Loading voting…