nimiq-block has skip block quorum bypass via out-of-range BitSet indices & u16 truncation
CVE-2026-33471GHSA-6973-8887-87ff
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nimiq-block 1.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io nimiq-block
- Affected
- < 1.7.2
- Fixed in
- 1.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6973-8887-87ff lists affected ranges: crates.io nimiq-block >=0 <=0.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6973-8887-87ff lists affected ranges: crates.io nimiq-block >=0 <1.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H
- EPSS
- CVE-2026-33471: 0.22% estimated exploitation activity in the next 30 days; percentile 12.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact `SkipBlockProof::verify` computes its quorum check using `BitSet.len()`, then iterates `BitSet` indices and casts each `usize` index to `u16` (`slot as u16`) for slot lookup. If an attacker can get a `SkipBlockProof` verified where `MultiSignature.signers` contains out-of-range indices spaced by 65536, these indices inflate `len()` but collide onto the same in-range `u16` slot during aggregation. This makes it possible for a malicious validator with far fewer than `2f+1` real signer slots to pass skip block proof verification by multiplying a single BLS signature by the same factor.
Patches The patch for this vulnerability is included as part of v1.3.0.
Workarounds No known workarounds.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-6973-8887-87ff
- Revision 1 · created ·
Published from ghsa record GHSA-6973-8887-87ff
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33471 Advisory: nimiq-block has skip block quorum bypass via out-of-range BitSet indices & u16 truncation IDs: CVE-2026-33471, GHSA-6973-8887-87ff Record: https://patchnext.com/advisories/cve-2026-33471 (revision 2, source checked 31 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nimiq-block 1.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io nimiq-block: affected < 1.7.2; fixed in 1.7.2 ## Suggested inspection (read-only) - crates.io nimiq-block: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nimiq-block. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6973-8887-87ff (GitHub-reviewed advisory GHSA-6973-8887-87ff lists affected ranges: crates.io nimiq-block >=0 <=0.2.0) - Verified: https://osv.dev/vulnerability/GHSA-6973-8887-87ff (OSV record GHSA-6973-8887-87ff lists affected ranges: crates.io nimiq-block >=0 <1.7.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…