Skip to content

← Actionable
High, CVSS 8.1amended

Kysely has a MySQL SQL Injection via Insufficient Backslash Escaping in sql.lit(string) usage or similar methods that append string literal values into the compiled SQL strings

CVE-2026-33468GHSA-8cpq-38p9-67gx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kysely 0.28.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm kysely

    Affected
    <= 0.28.13
    Fixed in
    0.28.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-33468: 0.43% estimated exploitation activity in the next 30 days; percentile 36.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Kysely's DefaultQueryCompiler.sanitizeStringLiteral() only escapes single quotes by doubling them (' → '') but does not escape backslashes. When used with the MySQL dialect (where NOBACKSLASHESCAPES is OFF by default), an attacker can use a backslash to escape the trailing quote of a string literal, breaking out of the string context and injecting arbitrary SQL. This affects any code path that uses ImmediateValueTransformer to inline values — specifically CreateIndexBuilder.where() and CreateViewBuilder.as(). Details The root cause is in DefaultQueryCompiler.sanitizeStringLiteral(): src/query-compiler/default-query-compiler.ts:1819-1821 Where LITWRAPREGEX is defined as /'/g (line 121). This only doubles single quotes — it does not escape backslash characters. The function is called from appendStringLiteral() which wraps the sanitized value in single quotes: src/query-compiler/default-query-compiler.ts:1841-1845 This is reached when visitValue() encounters an immediate value…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8cpq-38p9-67gx

  2. Revision 1 · created ·

    Published from osv record GHSA-8cpq-38p9-67gx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33468

Advisory: Kysely has a MySQL SQL Injection via Insufficient Backslash Escaping in `sql.lit(string)` usage or similar methods that append string literal values into the compiled SQL strings
IDs: CVE-2026-33468, GHSA-8cpq-38p9-67gx
Record: https://patchnext.com/advisories/cve-2026-33468 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kysely 0.28.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm kysely: affected <= 0.28.13; fixed in 0.28.14

## Suggested inspection (read-only)
- `npm ls kysely --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kysely.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8cpq-38p9-67gx (OSV record GHSA-8cpq-38p9-67gx lists affected ranges: npm kysely >=0 <0.28.14 (fixed))
- Verified: https://github.com/advisories/GHSA-8cpq-38p9-67gx (GitHub-reviewed advisory GHSA-8cpq-38p9-67gx lists affected ranges: npm kysely >=0 <=0.28.13)

Commands are suggestions: review each one before running it.

Loading voting…