Elastic Package Registry has Improper Verification of Cryptographic Signature
CVE-2026-33467GHSA-r727-5pf6-47r2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/elastic/package-registry 1.38.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/elastic/package-registry
- Affected
- < 1.38.0
- Fixed in
- 1.38.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r727-5pf6-47r2 lists affected ranges: Go github.com/elastic/package-registry >=0 <1.38.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-33467: 0.14% estimated exploitation activity in the next 30 days; percentile 3.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Verification of Cryptographic Signature (CWE-347) in Elastic Package Registry could allow an attacker positioned to intercept network traffic, or to otherwise influence the contents served to a self-hosted registry, to substitute a tampered package without the integrity check failing closed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r727-5pf6-47r2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33467 Advisory: Elastic Package Registry has Improper Verification of Cryptographic Signature IDs: CVE-2026-33467, GHSA-r727-5pf6-47r2 Record: https://patchnext.com/advisories/cve-2026-33467 (revision 1, source checked 26 Oct 2026, 15:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/elastic/package-registry 1.38.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/elastic/package-registry: affected < 1.38.0; fixed in 1.38.0 ## Suggested inspection (read-only) - Go github.com/elastic/package-registry: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/elastic/package-registry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r727-5pf6-47r2 (GitHub-reviewed advisory GHSA-r727-5pf6-47r2 lists affected ranges: Go github.com/elastic/package-registry >=0 <1.38.0) Commands are suggestions: review each one before running it.
Loading voting…