Apache camel-coap allows header injection that can lead to remote code execution
CVE-2026-33453GHSA-695c-x5gc-94gj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-coap 4.18.1, 4.14.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.camel:camel-coap
- Affected
- >= 4.14.0, <= 4.14.5>= 4.18.0, < 4.18.1
- Fixed in
- 4.18.1, 4.14.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-695c-x5gc-94gj lists affected ranges: Maven org.apache.camel:camel-coap >=4.14.0 =4.18.0 <4.18.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-33453: 9.18% estimated exploitation activity in the next 30 days; percentile 95.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Camel's camel-coap component is vulnerable to header injection because it maps CoAP request URI query parameters directly into Camel message headers without applying a HeaderFilterStrategy. An unauthenticated attacker can send a crafted CoAP request to inject arbitrary Camel internal headers into the exchange. When a vulnerable route forwards that exchange to a header-sensitive downstream producer, the attacker may be able to control producer behavior. For example, in routes using camel-exec, injected headers can override the configured executable and arguments, which can result in arbitrary command execution with the privileges of the Camel process. Command output may be returned to the attacker in the CoAP response. This issue affects org.apache.camel:camel-coap from 4.14.0 through 4.14.5 and from 4.18.0 before 4.18.1. It is fixed in 4.14.6, 4.18.1, and 4.19.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-695c-x5gc-94gj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33453 Advisory: Apache camel-coap allows header injection that can lead to remote code execution IDs: CVE-2026-33453, GHSA-695c-x5gc-94gj Record: https://patchnext.com/advisories/cve-2026-33453 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-coap 4.18.1, 4.14.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.camel:camel-coap: affected >= 4.14.0, <= 4.14.5; >= 4.18.0, < 4.18.1; fixed in 4.18.1, 4.14.6 ## Suggested inspection (read-only) - Maven org.apache.camel:camel-coap: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.camel:camel-coap. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-695c-x5gc-94gj (GitHub-reviewed advisory GHSA-695c-x5gc-94gj lists affected ranges: Maven org.apache.camel:camel-coap >=4.14.0 =4.18.0 <4.18.1) Commands are suggestions: review each one before running it.
Loading voting…