Skip to content

← Actionable
High, CVSS 7.3amended

Briefcase: Windows MSI Installer Privilege Escalation via Insecure Directory Permissions

CVE-2026-33430GHSA-r3r2-35v9-v238

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (briefcase 0.3.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI briefcase

    Affected
    >= 0.3.0, < 0.3.26
    Fixed in
    0.3.26

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-33430: 0.14% estimated exploitation activity in the next 30 days; percentile 3.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If a developer uses Briefcase to produce an Windows MSI installer for a project, and that project is installed for All Users (i.e., per-machine scope), the installation process creates an directory that inherits all the permissions of the parent directory. Depending on the location chosen by the installing user, this may allow a low privilege but authenticated user to replace or modify the binaries installed by the application. If an administrator then runs the altered binary, the binary will run with elevated privileges. Patches The problem is caused by the template used to generate the WXS file for Windows projects. It was fixed with the following PRs: beeware/briefcase-windows-app-template#86 beeware/briefcase-windows-VisualStudio-template#85 These patches have been backported to the templates used in Briefcase 0.3.26, 0.4.0, and 0.4.1. Re-running briefcase create on your Briefcase project will result in the updated templates being used. Workarounds The change from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r3r2-35v9-v238

  2. Revision 1 · created ·

    Published from osv record GHSA-r3r2-35v9-v238

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33430

Advisory: Briefcase: Windows MSI Installer Privilege Escalation via Insecure Directory Permissions
IDs: CVE-2026-33430, GHSA-r3r2-35v9-v238
Record: https://patchnext.com/advisories/cve-2026-33430 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: briefcase 0.3.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI briefcase: affected >= 0.3.0, < 0.3.26; fixed in 0.3.26

## Suggested inspection (read-only)
- `python -m pip show briefcase`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on briefcase.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r3r2-35v9-v238 (OSV record GHSA-r3r2-35v9-v238 lists affected ranges: PyPI briefcase >=0.3.0 <0.3.26 (fixed))
- Verified: https://github.com/advisories/GHSA-r3r2-35v9-v238 (GitHub-reviewed advisory GHSA-r3r2-35v9-v238 lists affected ranges: PyPI briefcase >=0.3.0 <0.3.26)

Commands are suggestions: review each one before running it.

Loading voting…