Skip to content

← Actionable
High, CVSS 8.8

etcd: Authorization bypasses in multiple APIs

CVE-2026-33413GHSA-q8m4-xhhv-38mg

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go go.etcd.io/etcd/v3

    Affected
    >= 3.6.0-alpha.0, <= 3.6.8>= 3.5.0-alpha.0, <= 3.5.27<= 3.4.41
    Fixed in
    3.6.9, 3.4.42, 3.5.28
  • Go go.etcd.io/etcd

    Affected
    <= 3.3.27
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33413: 0.26% estimated exploitation activity in the next 30 days; percentile 17.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? Multiple vulnerabilities allow unauthorized users to bypass authentication or authorization checks and call certain etcd functions in clusters that expose the gRPC API to untrusted or partially trusted clients. In unpatched etcd clusters with etcd auth enabled, unauthorized users are able to: - call MemberList and learn cluster topology, including member IDs and advertised endpoints - call Alarm, which can be abused for operational disruption or denial of service - use Lease APIs, interfering with TTL-based keys and lease ownership - trigger compaction, permanently removing historical revisions and disrupting watch, audit, and recovery workflows Kubernetes does not rely on etcd’s built-in authentication and authorization. Instead, the API server handles authentication and authorization itself, so typical Kubernetes deployments are not affected. Patches Has the problem been patched? What versions should users upgrade to? These…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q8m4-xhhv-38mg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33413

Advisory: etcd: Authorization bypasses in multiple APIs
IDs: CVE-2026-33413, GHSA-q8m4-xhhv-38mg
Record: https://patchnext.com/advisories/cve-2026-33413 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: go.etcd.io/etcd/v3 3.6.9, 3.5.28, 3.4.42. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go go.etcd.io/etcd/v3: affected >= 3.6.0-alpha.0, <= 3.6.8; >= 3.5.0-alpha.0, <= 3.5.27; <= 3.4.41; fixed in 3.6.9, 3.4.42, 3.5.28
- Go go.etcd.io/etcd: affected <= 3.3.27

## Suggested inspection (read-only)
- Go go.etcd.io/etcd/v3: check the installed version with your package manager.
- Go go.etcd.io/etcd: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on go.etcd.io/etcd/v3, go.etcd.io/etcd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q8m4-xhhv-38mg (GitHub-reviewed advisory GHSA-q8m4-xhhv-38mg lists affected ranges: Go go.etcd.io/etcd/v3 >=3.6.0-alpha.0 =3.5.0-alpha.0 =0 =0 <=3.3.27)

Commands are suggestions: review each one before running it.

Loading voting…