Parse Server has an auth provider validation bypass on login via partial authData
CVE-2026-33409GHSA-pfj7-wv7c-22pr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.41, 8.6.52), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.6.0-alpha.41< 8.6.52
- Fixed in
- 8.6.52, 9.6.0-alpha.41
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pfj7-wv7c-22pr lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.52 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pfj7-wv7c-22pr lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.52
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.0 · CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-33409: 0.47% estimated exploitation activity in the next 30 days; percentile 40.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. Patches Auth providers are now always validated on login, regardless of the allowExpiredAuthDataToken setting. The option allowExpiredAuthDataToken has been deprecated and will be removed in a future major version. Workarounds Set allowExpiredAuthDataToken to false (the default) or remove the option from the server configuration.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pfj7-wv7c-22pr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pfj7-wv7c-22pr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33409 Advisory: Parse Server has an auth provider validation bypass on login via partial authData IDs: CVE-2026-33409, GHSA-pfj7-wv7c-22pr Record: https://patchnext.com/advisories/cve-2026-33409 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.41, 8.6.52. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.41; < 8.6.52; fixed in 8.6.52, 9.6.0-alpha.41 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pfj7-wv7c-22pr (OSV record GHSA-pfj7-wv7c-22pr lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.52 (fixed)) - Verified: https://github.com/advisories/GHSA-pfj7-wv7c-22pr (GitHub-reviewed advisory GHSA-pfj7-wv7c-22pr lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.52) Commands are suggestions: review each one before running it.
Loading voting…