Protocol-Relative URL Injection via Single Backslash Bypass in Angular SSR
CVE-2026-33397GHSA-vfx2-hv2g-xj5f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@angular/ssr 22.0.0-next.2, 21.2.3, 20.3.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @angular/ssr
- Affected
- >= 22.0.0-next.0, < 22.0.0-next.2>= 21.0.0-next.0, < 21.2.3>= 20.0.0-next.0, < 20.3.21
- Fixed in
- 20.3.21, 22.0.0-next.2, 21.2.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vfx2-hv2g-xj5f lists affected ranges: npm @angular/ssr >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 <20.3.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vfx2-hv2g-xj5f lists affected ranges: npm @angular/ssr >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 <20.3.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-33397: 0.26% estimated exploitation activity in the next 30 days; percentile 17.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An Open Redirect vulnerability exists in @angular/ssr due to an incomplete fix for CVE-2026-27738. While the original fix successfully blocked multiple leading slashes (e.g., ///), the internal validation logic fails to account for a single backslash (\) bypass. When an Angular SSR application is deployed behind a proxy that passes the X-Forwarded-Prefix header: - An attacker provides a value starting with a single backslash (e.g., \evil.com). - The internal validation failed to flag the single backslash as invalid. - The application prepends a leading forward slash, resulting in a Location header containing /\evil.com. - Modern browsers interpret the /\ sequence as //, treating it as a protocol-relative URL and redirecting the user to the attacker-controlled domain. Furthermore, the response lacks the Vary: X-Forwarded-Prefix header, allowing the malicious redirect to be stored in intermediate caches (Web Cache Poisoning). Impact This vulnerability allows attackers to conduct…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vfx2-hv2g-xj5f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vfx2-hv2g-xj5f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33397 Advisory: Protocol-Relative URL Injection via Single Backslash Bypass in Angular SSR IDs: CVE-2026-33397, GHSA-vfx2-hv2g-xj5f Record: https://patchnext.com/advisories/cve-2026-33397 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @angular/ssr 22.0.0-next.2, 21.2.3, 20.3.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/ssr: affected >= 22.0.0-next.0, < 22.0.0-next.2; >= 21.0.0-next.0, < 21.2.3; >= 20.0.0-next.0, < 20.3.21; fixed in 20.3.21, 22.0.0-next.2, 21.2.3 ## Suggested inspection (read-only) - `npm ls @angular/ssr --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/ssr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vfx2-hv2g-xj5f (OSV record GHSA-vfx2-hv2g-xj5f lists affected ranges: npm @angular/ssr >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 <20.3.21 (fixed)) - Verified: https://github.com/advisories/GHSA-vfx2-hv2g-xj5f (GitHub-reviewed advisory GHSA-vfx2-hv2g-xj5f lists affected ranges: npm @angular/ssr >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 <20.3.21) Commands are suggestions: review each one before running it.
Loading voting…