Skip to content

← Actionable
Medium, CVSS 6.3

league/commonmark has an embed extension allowed_domains bypass

CVE-2026-33347GHSA-hh8v-hgvp-g3f5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (league/commonmark 2.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-33347: 0.25% estimated exploitation activity in the next 30 days; percentile 16.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The DomainFilteringAdapter in the Embed extension is vulnerable to an allowlist bypass due to a missing hostname boundary assertion in the domain-matching regex. An attacker-controlled domain like youtube.com.evil passes the allowlist check when youtube.com is an allowed domain. This enables two attack vectors: - SSRF: The OscaroteroEmbedAdapter makes server-side HTTP requests to the embed URL via the embed/embed library. A bypassed domain filter causes the server to make outbound requests to an attacker-controlled host, potentially probing internal services or exfiltrating request metadata. - XSS: EmbedRenderer outputs the oEmbed response HTML directly into the page with no sanitization. An attacker controlling the bypassed domain can return arbitrary HTML/JavaScript in their oEmbed response, which is rendered verbatim. Any application using the Embed extension and relying on alloweddomains to restrict domains when processing untrusted Markdown input is affected. Patches This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hh8v-hgvp-g3f5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33347

Advisory: league/commonmark has an embed extension allowed_domains bypass
IDs: CVE-2026-33347, GHSA-hh8v-hgvp-g3f5
Record: https://patchnext.com/advisories/cve-2026-33347 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: league/commonmark 2.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist league/commonmark: affected >= 2.3.0, <= 2.8.1; fixed in 2.8.2

## Suggested inspection (read-only)
- Packagist league/commonmark: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on league/commonmark.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hh8v-hgvp-g3f5 (GitHub-reviewed advisory GHSA-hh8v-hgvp-g3f5 lists affected ranges: Packagist league/commonmark >=2.3.0 <=2.8.1)

Commands are suggestions: review each one before running it.

Loading voting…