etcd: Nested etcd transactions bypass RBAC authorization checks
CVE-2026-33343GHSA-rfx7-8w68-q57q
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go go.etcd.io/etcd/v3
- Affected
- >= 3.6.0-alpha.0, <= 3.6.8>= 3.5.0-alpha.0, <= 3.5.27<= 3.4.41
- Fixed in
- 3.6.9, 3.4.42, 3.5.28
Go go.etcd.io/etcd
- Affected
- <= 3.3.27
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rfx7-8w68-q57q lists affected ranges: Go go.etcd.io/etcd/v3 >=3.6.0-alpha.0 =3.5.0-alpha.0 =0 =0 <=3.3.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-33343: 0.22% estimated exploitation activity in the next 30 days; percentile 12.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? An authenticated user with RBAC restricted permissions on key ranges can use nested transactions to bypass all key-level authorization. This allows any authenticated user with direct access to etcd to effectively ignore all key range restrictions, accessing the entire etcd data store. Kubernetes does not rely on etcd’s built-in authentication and authorization. Instead, the API server handles authentication and authorization itself, so typical Kubernetes deployments are not affected. Patches Has the problem been patched? What versions should users upgrade to? This vulnerability is patched in the following versions: etcd 3.6.9 etcd 3.5.28 etcd 3.4.42 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? If upgrading is not immediately possible, reduce exposure by treating the affected RPCs as unauthenticated in practice. restrict network access to etcd server ports so only trusted…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rfx7-8w68-q57q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33343 Advisory: etcd: Nested etcd transactions bypass RBAC authorization checks IDs: CVE-2026-33343, GHSA-rfx7-8w68-q57q Record: https://patchnext.com/advisories/cve-2026-33343 (revision 1, source checked 26 Oct 2026, 15:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: go.etcd.io/etcd/v3 3.6.9, 3.5.28, 3.4.42. A vendor fix does not mean a deployment is fixed. ## Affected components - Go go.etcd.io/etcd/v3: affected >= 3.6.0-alpha.0, <= 3.6.8; >= 3.5.0-alpha.0, <= 3.5.27; <= 3.4.41; fixed in 3.6.9, 3.4.42, 3.5.28 - Go go.etcd.io/etcd: affected <= 3.3.27 ## Suggested inspection (read-only) - Go go.etcd.io/etcd/v3: check the installed version with your package manager. - Go go.etcd.io/etcd: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on go.etcd.io/etcd/v3, go.etcd.io/etcd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rfx7-8w68-q57q (GitHub-reviewed advisory GHSA-rfx7-8w68-q57q lists affected ranges: Go go.etcd.io/etcd/v3 >=3.6.0-alpha.0 =3.5.0-alpha.0 =0 =0 <=3.3.27) Commands are suggestions: review each one before running it.
Loading voting…