Actual has Privilege Escalation via 'change-password' Endpoint on OpenID-Migrated Servers
CVE-2026-33318GHSA-prp4-2f49-fcgp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@actual-app/sync-server 26.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 26.4.0
- Fixed in
- 26.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-prp4-2f49-fcgp lists affected ranges: npm @actual-app/sync-server >=0 <26.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-prp4-2f49-fcgp lists affected ranges: npm @actual-app/sync-server >=0 <26.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-33318: 0.47% estimated exploitation activity in the next 30 days; percentile 40.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Any authenticated user (including BASIC role) can escalate to ADMIN on servers migrated from password authentication to OpenID Connect. Three weaknesses combine: POST /account/change-password has no authorization check, allowing any session to overwrite the password hash; the inactive password auth row is never removed on migration; and the login endpoint accepts a client-supplied loginMethod that bypasses the server's active auth configuration. Together these allow an attacker to set a known password and authenticate as the anonymous admin account created during the multiuser migration. --- Details packages/sync-server/src/app-account.js:120-132 — the /account/change-password route validates only that a session exists. No admin role check is performed packages/sync-server/src/accounts/password.js:113-125 — changePassword() updates the hash with no current-password confirmation: packages/sync-server/src/accounts/password.js:56-62 — loginWithPassword() always authenticates as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-prp4-2f49-fcgp
- Revision 1 · created ·
Published from osv record GHSA-prp4-2f49-fcgp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33318 Advisory: Actual has Privilege Escalation via 'change-password' Endpoint on OpenID-Migrated Servers IDs: CVE-2026-33318, GHSA-prp4-2f49-fcgp Record: https://patchnext.com/advisories/cve-2026-33318 (revision 2, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @actual-app/sync-server 26.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @actual-app/sync-server: affected < 26.4.0; fixed in 26.4.0 ## Suggested inspection (read-only) - `npm ls @actual-app/sync-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @actual-app/sync-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-prp4-2f49-fcgp (OSV record GHSA-prp4-2f49-fcgp lists affected ranges: npm @actual-app/sync-server >=0 <26.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-prp4-2f49-fcgp (GitHub-reviewed advisory GHSA-prp4-2f49-fcgp lists affected ranges: npm @actual-app/sync-server >=0 <26.4.0) Commands are suggestions: review each one before running it.
Loading voting…