SVG Injection via Unsanitized Options in @dicebear/core and @dicebear/initials
CVE-2026-33311GHSA-mr9r-mww3-v6gv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@dicebear/initials 9.4.1, 8.0.3, 7.1.4, 6.1.4, 5.4.4; @dicebear/core 9.4.1, 8.0.3, 7.1.4, 6.1.4, 5.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 5.0.0, <= 5.4.3>= 6.0.0, <= 6.1.3>= 7.0.0, <= 7.1.3>= 8.0.0, <= 8.0.2>= 9.0.0, <= 9.4.0
- Fixed in
- 8.0.3, 7.1.4, 9.4.1, 6.1.4, 5.4.4
npm @dicebear/core
- Affected
- >= 5.0.0, <= 5.4.3>= 6.0.0, <= 6.1.3>= 7.0.0, <= 7.1.3>= 8.0.0, <= 8.0.2>= 9.0.0, <= 9.4.0
- Fixed in
- 8.0.3, 7.1.4, 9.4.1, 6.1.4, 5.4.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mr9r-mww3-v6gv lists affected ranges: npm @dicebear/core >=5.0.0 =6.0.0 =7.0.0 =8.0.0 =9.0.0 =5.0.0 =6.0.0 =7.0.0 =8.0.0 =9.0.0 <9.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mr9r-mww3-v6gv lists affected ranges: npm @dicebear/core >=5.0.0 =6.0.0 =7.0.0 =8.0.0 =9.0.0 =5.0.0 =6.0.0 =7.0.0 =8.0.0 =9.0.0 <=9.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-33311: 0.19% estimated exploitation activity in the next 30 days; percentile 8.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary SVG attribute values derived from user-supplied options (backgroundColor, fontFamily, textColor) were not XML-escaped before interpolation into SVG output. This could allow Cross-Site Scripting (XSS) when applications pass untrusted input to createAvatar() and serve the resulting SVG inline or with Content-Type: image/svg+xml. Affected packages - @dicebear/core — backgroundColor option values interpolated into SVG attributes without escaping (affects solid and gradientLinear background types) - @dicebear/initials — fontFamily and textColor option values interpolated into SVG attributes without escaping Fix All affected SVG attribute values are now properly escaped using XML entity encoding. Users should upgrade to the listed patched versions. Mitigating factors - Applications that validate input against the library's JSON Schema before passing it to createAvatar() are not affected - The DiceBear CLI validates input via AJV and was not vulnerable - Exploitation requires that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mr9r-mww3-v6gv
- Revision 1 · created ·
Published from osv record GHSA-mr9r-mww3-v6gv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33311 Advisory: SVG Injection via Unsanitized Options in @dicebear/core and @dicebear/initials IDs: CVE-2026-33311, GHSA-mr9r-mww3-v6gv Record: https://patchnext.com/advisories/cve-2026-33311 (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @dicebear/initials 9.4.1, 8.0.3, 7.1.4, 6.1.4, 5.4.4; @dicebear/core 9.4.1, 8.0.3, 7.1.4, 6.1.4, 5.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @dicebear/initials: affected >= 5.0.0, <= 5.4.3; >= 6.0.0, <= 6.1.3; >= 7.0.0, <= 7.1.3; >= 8.0.0, <= 8.0.2; >= 9.0.0, <= 9.4.0; fixed in 8.0.3, 7.1.4, 9.4.1, 6.1.4, 5.4.4 - npm @dicebear/core: affected >= 5.0.0, <= 5.4.3; >= 6.0.0, <= 6.1.3; >= 7.0.0, <= 7.1.3; >= 8.0.0, <= 8.0.2; >= 9.0.0, <= 9.4.0; fixed in 8.0.3, 7.1.4, 9.4.1, 6.1.4, 5.4.4 ## Suggested inspection (read-only) - `npm ls @dicebear/initials --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @dicebear/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @dicebear/initials, @dicebear/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mr9r-mww3-v6gv (OSV record GHSA-mr9r-mww3-v6gv lists affected ranges: npm @dicebear/core >=5.0.0 =6.0.0 =7.0.0 =8.0.0 =9.0.0 =5.0.0 =6.0.0 =7.0.0 =8.0.0 =9.0.0 <9.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-mr9r-mww3-v6gv (GitHub-reviewed advisory GHSA-mr9r-mww3-v6gv lists affected ranges: npm @dicebear/core >=5.0.0 =6.0.0 =7.0.0 =8.0.0 =9.0.0 =5.0.0 =6.0.0 =7.0.0 =8.0.0 =9.0.0 <=9.4.0) Commands are suggestions: review each one before running it.
Loading voting…