Langflow has an Arbitrary File Write (RCE) via v2 API
CVE-2026-33309GHSA-g2j9-7rj2-gm6c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow
- Affected
- >= 1.2.0, < 1.9.0
- Fixed in
- 1.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g2j9-7rj2-gm6c lists affected ranges: PyPI langflow >=1.2.0 <1.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g2j9-7rj2-gm6c lists affected ranges: PyPI langflow >=1.2.0 <1.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-33309: 13.47% estimated exploitation activity in the next 30 days; percentile 96.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary While reviewing the recent patch for CVE-2025-68478 (External Control of File Name in v1.7.1), I discovered that the root architectural issue within LocalStorageService remains unresolved. Because the underlying storage layer lacks boundary containment checks, the system relies entirely on the HTTP-layer ValidatedFileName dependency. This defense-in-depth failure leaves the POST /api/v2/files/ endpoint vulnerable to Arbitrary File Write. The multipart upload filename bypasses the path-parameter guard, allowing authenticated attackers to write files anywhere on the host system, leading to Remote Code Execution (RCE). Details The vulnerability exists in two layers: 1. API Layer (src/backend/base/langflow/api/v2/files.py:162): Inside the uploaduserfile route, the filename is extracted directly from the multipart Content-Disposition header (newfilename = file.filename). It is passed verbatim to the storage service. ValidatedFileName provides zero protection here as it only guards…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g2j9-7rj2-gm6c
- Revision 2 · amended ·
Amended from osv record GHSA-g2j9-7rj2-gm6c
- Revision 1 · created ·
Published from ghsa record GHSA-g2j9-7rj2-gm6c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33309 Advisory: Langflow has an Arbitrary File Write (RCE) via v2 API IDs: CVE-2026-33309, GHSA-g2j9-7rj2-gm6c Record: https://patchnext.com/advisories/cve-2026-33309 (revision 3, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langflow 1.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow: affected >= 1.2.0, < 1.9.0; fixed in 1.9.0 ## Suggested inspection (read-only) - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g2j9-7rj2-gm6c (GitHub-reviewed advisory GHSA-g2j9-7rj2-gm6c lists affected ranges: PyPI langflow >=1.2.0 <1.9.0) - Verified: https://osv.dev/vulnerability/GHSA-g2j9-7rj2-gm6c (OSV record GHSA-g2j9-7rj2-gm6c lists affected ranges: PyPI langflow >=1.2.0 <1.9.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…