Skip to content

← Actionable
High, CVSS 7.5

Ella Core panics on malformed NGAP Location Report

CVE-2026-33282GHSA-826q-wrq4-p23x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ellanetworks/core 1.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-33282: 0.41% estimated exploitation activity in the next 30 days; percentile 35.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Ella Core panics when processing a malformed NGAP LocationReport message with ue-presence-in-area-of-interest event type and omitting the optional UEPresenceInAreaOfInterestList IE. Impact An attacker able to send crafted NGAP messages to Ella Core can crash the process, causing service disruption for all connected subscribers. No authentication is required. Fix Added IE presence verification to NGAP message handling.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-826q-wrq4-p23x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33282

Advisory: Ella Core panics on malformed NGAP Location Report
IDs: CVE-2026-33282, GHSA-826q-wrq4-p23x
Record: https://patchnext.com/advisories/cve-2026-33282 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ellanetworks/core 1.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ellanetworks/core: affected < 1.6.0; fixed in 1.6.0

## Suggested inspection (read-only)
- Go github.com/ellanetworks/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ellanetworks/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-826q-wrq4-p23x (GitHub-reviewed advisory GHSA-826q-wrq4-p23x lists affected ranges: Go github.com/ellanetworks/core >=0 <1.6.0)

Commands are suggestions: review each one before running it.

Loading voting…