Apache Airflow allows code execution through unsafe serialized DAG deserialization
CVE-2026-33264GHSA-2943-9672-r45w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- < 3.3.0
- Fixed in
- 3.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2943-9672-r45w lists affected ranges: PyPI apache-airflow >=0 <3.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2943-9672-r45w lists affected ranges: PyPI apache-airflow >=0 <3.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-33264: 1.65% estimated exploitation activity in the next 30 days; percentile 76.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A bug in BaseSerialization.deserialize() allowed unrestricted importstring() of attacker-controlled class paths when the Scheduler / API Server loaded a serialized DAG: a DAG author could embed a malicious trigger into a DAG to gain remote code execution on the API Server / Scheduler process, crossing the Airflow security boundary that DAG-author code must never execute in those processes. Users are advised to upgrade to apache-airflow 3.3.0 or later. As a defense-in-depth mitigation, deployments where DAG-author trust is limited can restrict the [core] alloweddeserializationclasses config to a narrow allowlist.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2943-9672-r45w
- Revision 2 · amended ·
Amended from osv record GHSA-2943-9672-r45w
- Revision 1 · created ·
Published from ghsa record GHSA-2943-9672-r45w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33264 Advisory: Apache Airflow allows code execution through unsafe serialized DAG deserialization IDs: CVE-2026-33264, GHSA-2943-9672-r45w Record: https://patchnext.com/advisories/cve-2026-33264 (revision 3, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected < 3.3.0; fixed in 3.3.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2943-9672-r45w (GitHub-reviewed advisory GHSA-2943-9672-r45w lists affected ranges: PyPI apache-airflow >=0 <3.3.0) - Verified: https://osv.dev/vulnerability/GHSA-2943-9672-r45w (OSV record GHSA-2943-9672-r45w lists affected ranges: PyPI apache-airflow >=0 <3.3.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…