Skip to content

← Actionable
High, CVSS 8.1amended

NLTK has a Downloader Path Traversal Vulnerability (AFO) - Arbitrary File Overwrite

CVE-2026-33236GHSA-469j-vmhf-r6v7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nltk

    Affected
    < 3.9.4
    Fixed in
    3.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-33236: 0.60% estimated exploitation activity in the next 30 days; percentile 48.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Description The NLTK downloader does not validate the `subdir` and `id` attributes when processing remote XML index files. Attackers can control a remote XML index server to provide malicious values containing path traversal sequences (such as `../`), which can lead to: 1. Arbitrary Directory Creation: Create directories at arbitrary locations in the file system 2. Arbitrary File Creation: Create arbitrary files 3. Arbitrary File Overwrite: Overwrite critical system files (such as `/etc/passwd`, `~/.ssh/authorized_keys`, etc.)

Vulnerability Principle

Key Code Locations 1. XML Parsing Without Validation (`nltk/downloader.py:253`) ```python self.filename = os.path.join(subdir, id + ext) ``` - `subdir` and `id` are directly from XML attributes without any validation 2. Path Construction Without Checks (`nltk/downloader.py:679`) ```python filepath = os.path.join(download_dir, info.filename) ``` - Directly uses `filename` which may contain path…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-469j-vmhf-r6v7

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-469j-vmhf-r6v7

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-469j-vmhf-r6v7

  4. Revision 1 · created ·

    Published from osv record GHSA-469j-vmhf-r6v7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33236

Advisory: NLTK has a Downloader Path Traversal Vulnerability (AFO) - Arbitrary File Overwrite
IDs: CVE-2026-33236, GHSA-469j-vmhf-r6v7
Record: https://patchnext.com/advisories/cve-2026-33236 (revision 4, source checked 4 Nov 2026, 06:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nltk 3.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nltk: affected < 3.9.4; fixed in 3.9.4

## Suggested inspection (read-only)
- `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nltk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-469j-vmhf-r6v7 (OSV record GHSA-469j-vmhf-r6v7 lists affected ranges: PyPI nltk >=0 <=3.9.2)
- Verified: https://github.com/advisories/GHSA-469j-vmhf-r6v7 (GitHub-reviewed advisory GHSA-469j-vmhf-r6v7 lists affected ranges: PyPI nltk >=0 <=3.9.2)
- Verified: https://github.com/advisories/GHSA-469j-vmhf-r6v7 (GitHub-reviewed advisory GHSA-469j-vmhf-r6v7 lists affected ranges: PyPI nltk >=0 <3.9.4)
- Verified: https://osv.dev/vulnerability/GHSA-469j-vmhf-r6v7 (OSV record GHSA-469j-vmhf-r6v7 lists affected ranges: PyPI nltk >=0 <3.9.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…