Unauthenticated remote shutdown in nltk.app.wordnet_app
CVE-2026-33231GHSA-jm6w-m3j8-898g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.9.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nltk
- Affected
- <= 3.9.3
- Fixed in
- 3.9.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jm6w-m3j8-898g lists affected ranges: PyPI nltk >=0 <3.9.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jm6w-m3j8-898g lists affected ranges: PyPI nltk >=0 <=3.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-33231: 1.24% estimated exploitation activity in the next 30 days; percentile 69.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary nltk.app.wordnetapp allows unauthenticated remote shutdown of the local WordNet Browser HTTP server when it is started in its default mode. A simple GET /SHUTDOWN%20THE%20SERVER request causes the process to terminate immediately via os.exit(0), resulting in a denial of service. Details The vulnerable logic is in nltk/app/wordnetapp.py: - nltk/app/wordnetapp.py:242 - The server listens on all interfaces: - server = HTTPServer(("", port), MyServerHandler) - nltk/app/wordnetapp.py:87 - Incoming requests are checked for the exact path: - if unquoteplus(sp) == "SHUTDOWN THE SERVER": - nltk/app/wordnetapp.py:88 - The shutdown protection only depends on servermode - nltk/app/wordnetapp.py:93 - In the default mode (runBrowser=True, therefore servermode=False), the handler terminates the process directly: - os.exit(0) This means any party that can reach the listening port can stop the service with a single unauthenticated GET request when the browser is started in its normal mode.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jm6w-m3j8-898g
- Revision 1 · created ·
Published from osv record GHSA-jm6w-m3j8-898g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33231 Advisory: Unauthenticated remote shutdown in nltk.app.wordnet_app IDs: CVE-2026-33231, GHSA-jm6w-m3j8-898g Record: https://patchnext.com/advisories/cve-2026-33231 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nltk 3.9.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nltk: affected <= 3.9.3; fixed in 3.9.4 ## Suggested inspection (read-only) - `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nltk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jm6w-m3j8-898g (OSV record GHSA-jm6w-m3j8-898g lists affected ranges: PyPI nltk >=0 <3.9.4 (fixed)) - Verified: https://github.com/advisories/GHSA-jm6w-m3j8-898g (GitHub-reviewed advisory GHSA-jm6w-m3j8-898g lists affected ranges: PyPI nltk >=0 <=3.9.3) Commands are suggestions: review each one before running it.
Loading voting…