Skip to content

← Actionable
Medium, CVSS 6.1amended

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in nltk

CVE-2026-33230GHSA-gfwx-w7gr-fvh7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nltk

    Affected
    <= 3.9.3
    Fixed in
    3.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-33230: 0.34% estimated exploitation activity in the next 30 days; percentile 27.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary nltk.app.wordnetapp contains a reflected cross-site scripting issue in the lookup... route. A crafted lookup<payload URL can inject arbitrary HTML/JavaScript into the response page because attacker-controlled word data is reflected into HTML without escaping. This impacts users running the local WordNet Browser server and can lead to script execution in the browser origin of that application. Details The vulnerable flow is in nltk/app/wordnetapp.py: - nltk/app/wordnetapp.py:144 - Requests starting with lookup are handled as HTML responses: - page, word = pagefromhref(sp) - nltk/app/wordnetapp.py:755 - pagefromhref() calls pagefromreference(Reference.decode(href)) - nltk/app/wordnetapp.py:769 - word = href.word - nltk/app/wordnetapp.py:796 - If no results are found, word is inserted directly into the HTML body: - body = "The word or words '%s' were not found in the dictionary." % word This is inconsistent with the search route, which does escape user input: -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gfwx-w7gr-fvh7

  2. Revision 1 · created ·

    Published from osv record GHSA-gfwx-w7gr-fvh7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33230

Advisory: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in nltk
IDs: CVE-2026-33230, GHSA-gfwx-w7gr-fvh7
Record: https://patchnext.com/advisories/cve-2026-33230 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nltk 3.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nltk: affected <= 3.9.3; fixed in 3.9.4

## Suggested inspection (read-only)
- `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nltk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gfwx-w7gr-fvh7 (OSV record GHSA-gfwx-w7gr-fvh7 lists affected ranges: PyPI nltk >=0 <3.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-gfwx-w7gr-fvh7 (GitHub-reviewed advisory GHSA-gfwx-w7gr-fvh7 lists affected ranges: PyPI nltk >=0 <=3.9.3)

Commands are suggestions: review each one before running it.

Loading voting…