XWiki vulnerable to remote code execution with script right through unprotected Velocity scripting API
CVE-2026-33229GHSA-h259-74h5-4rh9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 17.10.1, 17.4.8; org.xwiki.platform:xwiki-platform-legacy-oldcore 17.10.1, 17.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- >= 17.0.0-rc-1, < 17.4.8>= 17.5.0-rc-1, < 17.10.1
- Fixed in
- 17.10.1, 17.4.8
Maven org.xwiki.platform:xwiki-platform-legacy-oldcore
- Affected
- >= 17.0.0-rc-1, < 17.4.8>= 17.5.0-rc-1, < 17.10.1
- Fixed in
- 17.10.1, 17.4.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h259-74h5-4rh9 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=17.0.0-rc-1 =17.5.0-rc-1 =17.0.0-rc-1 =17.5.0-rc-1 <17.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-33229: 0.54% estimated exploitation activity in the next 30 days; percentile 45.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. Patches The vulnerability has been patched in XWiki 17.4.8 and 17.10.1 by requiring programming right to access the affected scripting API. Workarounds We're not aware of any workarounds except for being careful whom you grant script right. Attribution We thank Youssef Azefzaf for discovering and reporting this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h259-74h5-4rh9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33229 Advisory: XWiki vulnerable to remote code execution with script right through unprotected Velocity scripting API IDs: CVE-2026-33229, GHSA-h259-74h5-4rh9 Record: https://patchnext.com/advisories/cve-2026-33229 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 17.10.1, 17.4.8; org.xwiki.platform:xwiki-platform-legacy-oldcore 17.10.1, 17.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 17.0.0-rc-1, < 17.4.8; >= 17.5.0-rc-1, < 17.10.1; fixed in 17.10.1, 17.4.8 - Maven org.xwiki.platform:xwiki-platform-legacy-oldcore: affected >= 17.0.0-rc-1, < 17.4.8; >= 17.5.0-rc-1, < 17.10.1; fixed in 17.10.1, 17.4.8 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. - Maven org.xwiki.platform:xwiki-platform-legacy-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore, org.xwiki.platform:xwiki-platform-legacy-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h259-74h5-4rh9 (GitHub-reviewed advisory GHSA-h259-74h5-4rh9 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=17.0.0-rc-1 =17.5.0-rc-1 =17.0.0-rc-1 =17.5.0-rc-1 <17.10.1) Commands are suggestions: review each one before running it.
Loading voting…