Skip to content

← Actionable
Medium, CVSS 4.3

Apache ActiveMQ: Improper validation and restriction of a classpath path name

CVE-2026-33227GHSA-h2h4-5m64-m273

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-broker 6.2.2, 5.19.3; org.apache.activemq:activemq-client 6.2.2, 5.19.3; org.apache.activemq:activemq-web 6.2.2, 5.19.3; org.apache.activemq:activemq-all 6.2.2, 5.19.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-h2h4-5m64-m273 lists affected ranges: Maven org.apache.activemq:activemq-client >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.2.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-33227: 0.42% estimated exploitation activity in the next 30 days; percentile 36.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ. In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit. This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h2h4-5m64-m273

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33227

Advisory: Apache ActiveMQ: Improper validation and restriction of a classpath path name
IDs: CVE-2026-33227, GHSA-h2h4-5m64-m273
Record: https://patchnext.com/advisories/cve-2026-33227 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-broker 6.2.2, 5.19.3; org.apache.activemq:activemq-client 6.2.2, 5.19.3; org.apache.activemq:activemq-web 6.2.2, 5.19.3; org.apache.activemq:activemq-all 6.2.2, 5.19.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.activemq:activemq-broker: affected < 5.19.3; >= 6.0.0, < 6.2.2; fixed in 5.19.3, 6.2.2
- Maven org.apache.activemq:activemq-client: affected < 5.19.3; >= 6.0.0, < 6.2.2; fixed in 5.19.3, 6.2.2
- Maven org.apache.activemq:activemq-web: affected < 5.19.3; >= 6.0.0, < 6.2.2; fixed in 5.19.3, 6.2.2
- Maven org.apache.activemq:activemq-all: affected < 5.19.3; >= 6.0.0, < 6.2.2; fixed in 5.19.3, 6.2.2

## Suggested inspection (read-only)
- Maven org.apache.activemq:activemq-broker: check the installed version with your package manager.
- Maven org.apache.activemq:activemq-client: check the installed version with your package manager.
- Maven org.apache.activemq:activemq-web: check the installed version with your package manager.
- Maven org.apache.activemq:activemq-all: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.activemq:activemq-broker, org.apache.activemq:activemq-client, org.apache.activemq:activemq-web, org.apache.activemq:activemq-all.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h2h4-5m64-m273 (GitHub-reviewed advisory GHSA-h2h4-5m64-m273 lists affected ranges: Maven org.apache.activemq:activemq-client >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.2.2)

Commands are suggestions: review each one before running it.

Loading voting…