Skip to content

← Actionable
High, CVSS 7.5

SimpleJWT has an Unauthenticated Denial of Service via JWE header tampering

CVE-2026-33204GHSA-xw36-67f8-339x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kelvinmo/simplejwt 1.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-33204: 0.49% estimated exploitation activity in the next 30 days; percentile 42.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated attacker can perform a Denial of Service via JWE header tampering when PBES2 algorithms are used. Applications that call JWE::decrypt() on attacker-controlled JWEs using PBES2 algorithms are affected. Details PHP version: PHP 8.4.11 SimpleJWT version: v1.1.0 The relevant portion of the vulnerable implementation is shown below (PBES2.php): The security flaw lies in the lack of input validation when handling JWEs that uses PBES2. A "sanity ceiling" is not set on the iteration count, which is the parameter known in the JWE specification as p2c (RFC7518). The library calls decryptKey() with the untrusted input $headers which then use the PHP function hashpbkdf2() with the user-supplied value $headers['p2c']. This results in an algorithmic complexity denial-of-service (CPU exhaustion) because the PBKDF2 iteration count is fully attacker-controlled. Because the header is processed before successful decryption and authentication, the attack can be triggered using…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xw36-67f8-339x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33204

Advisory: SimpleJWT has an Unauthenticated Denial of Service via JWE header tampering
IDs: CVE-2026-33204, GHSA-xw36-67f8-339x
Record: https://patchnext.com/advisories/cve-2026-33204 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kelvinmo/simplejwt 1.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist kelvinmo/simplejwt: affected <= 1.1.0; fixed in 1.1.1

## Suggested inspection (read-only)
- Packagist kelvinmo/simplejwt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kelvinmo/simplejwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xw36-67f8-339x (GitHub-reviewed advisory GHSA-xw36-67f8-339x lists affected ranges: Packagist kelvinmo/simplejwt >=0 <=1.1.0)

Commands are suggestions: review each one before running it.

Loading voting…