Statamic is missing authorization check on taxonomy term creation via fieldtype
CVE-2026-33177GHSA-wh3h-gvc4-cc2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 6.7.0, 5.73.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist statamic/cms
- Affected
- >= 6.0.0-alpha.1, < 6.7.0< 5.73.14
- Fixed in
- 5.73.14, 6.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wh3h-gvc4-cc2g lists affected ranges: Packagist statamic/cms >=6.0.0-alpha.1 =0 <5.73.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-33177: 0.23% estimated exploitation activity in the next 30 days; percentile 14.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Low-privileged Control Panel users could create taxonomy terms by submitting requests to the field action processing endpoint with attacker-controlled field definitions. This bypasses the authorization checks enforced on the standard taxonomy term creation endpoint. Patches This has been fixed in 5.73.14 and 6.7.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wh3h-gvc4-cc2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33177 Advisory: Statamic is missing authorization check on taxonomy term creation via fieldtype IDs: CVE-2026-33177, GHSA-wh3h-gvc4-cc2g Record: https://patchnext.com/advisories/cve-2026-33177 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: statamic/cms 6.7.0, 5.73.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist statamic/cms: affected >= 6.0.0-alpha.1, < 6.7.0; < 5.73.14; fixed in 5.73.14, 6.7.0 ## Suggested inspection (read-only) - Packagist statamic/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on statamic/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wh3h-gvc4-cc2g (GitHub-reviewed advisory GHSA-wh3h-gvc4-cc2g lists affected ranges: Packagist statamic/cms >=6.0.0-alpha.1 =0 <5.73.14) Commands are suggestions: review each one before running it.
Loading voting…