Auth0OAuthenticator has an Authentication Bypass via Unverified Email Claims
CVE-2026-33175GHSA-rrvg-cxh4-qhrv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oauthenticator 17.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI oauthenticator
- Affected
- < 17.4.0
- Fixed in
- 17.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rrvg-cxh4-qhrv lists affected ranges: PyPI oauthenticator >=0 <17.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rrvg-cxh4-qhrv lists affected ranges: PyPI oauthenticator >=0 <17.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-33175: 0.45% estimated exploitation activity in the next 30 days; percentile 38.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authentication bypass vulnerability in oauthenticator allows an attacker with an unverified email address on an Auth0 tenant to login to JupyterHub. When email is used as the usrnameclaim, this gives users control over their username and the possibility of account takeover. Impact This is an Authentication Bypass Vulnerability. Any Auth0 tenant leveraging the Auth0OAuthenticator mapping the email claim to the JupyterHub username is impacted. By default, Auth0 handles email verification as a user flag, not a hard block to authentication streams. If an attacker can register an account with the Auth0 tenant with an unverified email and knows the email of an existing user on the system, they can authenticate as that user. Patches - Upgrade oauthenticator to 17.4 Workarounds - Check emailverified field in an Authenticator.postauthhook function - Do not use email as the username claim - Enforce email verification in auth0
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rrvg-cxh4-qhrv
- Revision 1 · created ·
Published from osv record GHSA-rrvg-cxh4-qhrv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33175 Advisory: Auth0OAuthenticator has an Authentication Bypass via Unverified Email Claims IDs: CVE-2026-33175, GHSA-rrvg-cxh4-qhrv Record: https://patchnext.com/advisories/cve-2026-33175 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oauthenticator 17.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI oauthenticator: affected < 17.4.0; fixed in 17.4.0 ## Suggested inspection (read-only) - `python -m pip show oauthenticator`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oauthenticator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rrvg-cxh4-qhrv (OSV record GHSA-rrvg-cxh4-qhrv lists affected ranges: PyPI oauthenticator >=0 <17.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rrvg-cxh4-qhrv (GitHub-reviewed advisory GHSA-rrvg-cxh4-qhrv lists affected ranges: PyPI oauthenticator >=0 <17.4.0) Commands are suggestions: review each one before running it.
Loading voting…