Skip to content

← Actionable
Medium, CVSS 6.9

Rails Active Support has a possible ReDoS vulnerability in number_to_delimited

CVE-2026-33169GHSA-cg4j-q9v8-6v38

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (activesupport 8.1.2.1, 8.0.4.1, 7.2.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems activesupport

    Affected
    >= 8.1.0.beta1, < 8.1.2.1>= 8.0.0.beta1, < 8.0.4.1< 7.2.3.1
    Fixed in
    7.2.3.1, 8.1.2.1, 8.0.4.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33169: 0.66% estimated exploitation activity in the next 30 days; percentile 51.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact NumberToDelimitedConverter used a regular expression with gsub! to insert thousands delimiters. This could produce quadratic time complexity on long digit strings. Releases The fixed releases are available at the normal locations. Credit This issue was responsibly reported by Hackerone researcher scyoon.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cg4j-q9v8-6v38

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33169

Advisory: Rails Active Support has a possible ReDoS vulnerability in number_to_delimited
IDs: CVE-2026-33169, GHSA-cg4j-q9v8-6v38
Record: https://patchnext.com/advisories/cve-2026-33169 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: activesupport 8.1.2.1, 8.0.4.1, 7.2.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems activesupport: affected >= 8.1.0.beta1, < 8.1.2.1; >= 8.0.0.beta1, < 8.0.4.1; < 7.2.3.1; fixed in 7.2.3.1, 8.1.2.1, 8.0.4.1

## Suggested inspection (read-only)
- RubyGems activesupport: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on activesupport.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cg4j-q9v8-6v38 (GitHub-reviewed advisory GHSA-cg4j-q9v8-6v38 lists affected ranges: RubyGems activesupport >=8.1.0.beta1 =8.0.0.beta1 =0 <7.2.3.1)

Commands are suggestions: review each one before running it.

Loading voting…