Skip to content

← Actionable
Medium, CVSS 4.9

Craft CMS: Low-privilege users could read private asset contents when editing an asset (IDOR)

CVE-2026-33158GHSA-3pvf-vxrv-hh9c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.9.14, 4.17.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 4.0.0-RC1, <= 4.17.7>= 5.0.0-RC1, <= 5.9.13
    Fixed in
    5.9.14, 4.17.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-33158: 0.36% estimated exploitation activity in the next 30 days; percentile 29.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A low-privileged authenticated user can read private asset content by calling assets/edit-image with an arbitrary assetId that they are not authorized to view. The endpoint returns image bytes (or a preview redirect) without enforcing a per-asset view authorization check, leading to potential unauthorized disclosure of private files. Details Root cause: - A user-controlled object reference (assetId) is used to load and return sensitive content. - The action does not verify whether the current user is authorized to view that asset. - This creates an authenticated IDOR / authorization bypass. Impact - Craft installations where private/non-public assets exist and low-privileged users can authenticate. Resources https://github.com/craftcms/cms/commit/7290d91639e

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3pvf-vxrv-hh9c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33158

Advisory: Craft CMS: Low-privilege users could read private asset contents when editing an asset (IDOR)
IDs: CVE-2026-33158, GHSA-3pvf-vxrv-hh9c
Record: https://patchnext.com/advisories/cve-2026-33158 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.9.14, 4.17.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 4.0.0-RC1, <= 4.17.7; >= 5.0.0-RC1, <= 5.9.13; fixed in 5.9.14, 4.17.8

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3pvf-vxrv-hh9c (GitHub-reviewed advisory GHSA-3pvf-vxrv-hh9c lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <=5.9.13)

Commands are suggestions: review each one before running it.

Loading voting…