Skip to content

← Actionable
High, CVSS 8.7amended

DeepDiff has Memory Exhaustion DoS through SAFE_TO_IMPORT

CVE-2026-33155GHSA-54jj-px8x-5w5q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deepdiff 8.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI deepdiff

    Affected
    >= 5.0.0, <= 8.6.1
    Fixed in
    8.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33155: 0.46% estimated exploitation activity in the next 30 days; percentile 39.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The pickle unpickler RestrictedUnpickler validates which classes can be loaded but does not limit their constructor arguments. A few of the types in SAFETOIMPORT have constructors that allocate memory proportional to their input (builtins.bytes, builtins.list, builtins.range). A 40-byte pickle payload can force 10+ GB of memory, which crashes applications that load delta objects or call pickleload with untrusted data. Details CVE-2025-58367 hardened the delta class against pollution and remote code execution by converting SAFETOIMPORT to a frozenset and blocking traversal. RestrictedUnpickler.findclass only gates which classes can be loaded. It doesn't intercept REDUCE opcodes or validate what is passed to constructors. It can be exploited in 2 ways. 1 - During pickleload A pickle that calls bytes(N) using opcodes permitted by the allowlist. The allocation happens during deserialization and before the delta processes anything. The restricted unpickler does not override…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-54jj-px8x-5w5q

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-54jj-px8x-5w5q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33155

Advisory: DeepDiff has Memory Exhaustion DoS through SAFE_TO_IMPORT
IDs: CVE-2026-33155, GHSA-54jj-px8x-5w5q
Record: https://patchnext.com/advisories/cve-2026-33155 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deepdiff 8.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI deepdiff: affected >= 5.0.0, <= 8.6.1; fixed in 8.6.2

## Suggested inspection (read-only)
- `python -m pip show deepdiff`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deepdiff.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-54jj-px8x-5w5q (OSV record GHSA-54jj-px8x-5w5q lists affected ranges: PyPI deepdiff >=5.0.0 <8.6.2 (fixed))
- Verified: https://github.com/advisories/GHSA-54jj-px8x-5w5q (GitHub-reviewed advisory GHSA-54jj-px8x-5w5q lists affected ranges: PyPI deepdiff >=5.0.0 <=8.6.1)

Commands are suggestions: review each one before running it.

Loading voting…