dynaconf Affected by Remote Code Execution (RCE) via Insecure Template Evaluation in @jinja Resolver
CVE-2026-33154GHSA-pxrr-hq57-q35p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dynaconf 3.2.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dynaconf
- Affected
- <= 3.2.12
- Fixed in
- 3.2.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pxrr-hq57-q35p lists affected ranges: PyPI dynaconf >=0 <3.2.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pxrr-hq57-q35p lists affected ranges: PyPI dynaconf >=0 <=3.2.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-33154: 0.54% estimated exploitation activity in the next 30 days; percentile 45.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Dynaconf is vulnerable to Server-Side Template Injection (SSTI) due to unsafe template evaluation in the @jinja resolver. When the jinja2 package is installed, Dynaconf evaluates template expressions embedded in configuration values without a sandboxed environment. If an attacker can influence configuration sources such as: environment variables .env files container environment configuration CI/CD secrets they can execute arbitrary OS commands on the host system. In addition, the @format resolver allows object graph traversal, which may expose sensitive runtime objects and environment variables. Details The vulnerability arises because Dynaconf's string resolvers lack proper security boundaries. 1. @jinja Resolver The @jinja resolver renders templates using full Jinja2 evaluation. However, the rendering context is not sandboxed, which allows attackers to access Python's internal attributes. Using objects such as cycler, attackers can reach Python's globals and import the os…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pxrr-hq57-q35p
- Revision 1 · created ·
Published from osv record GHSA-pxrr-hq57-q35p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33154 Advisory: dynaconf Affected by Remote Code Execution (RCE) via Insecure Template Evaluation in @jinja Resolver IDs: CVE-2026-33154, GHSA-pxrr-hq57-q35p Record: https://patchnext.com/advisories/cve-2026-33154 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dynaconf 3.2.13. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dynaconf: affected <= 3.2.12; fixed in 3.2.13 ## Suggested inspection (read-only) - `python -m pip show dynaconf`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dynaconf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pxrr-hq57-q35p (OSV record GHSA-pxrr-hq57-q35p lists affected ranges: PyPI dynaconf >=0 <3.2.13 (fixed)) - Verified: https://github.com/advisories/GHSA-pxrr-hq57-q35p (GitHub-reviewed advisory GHSA-pxrr-hq57-q35p lists affected ranges: PyPI dynaconf >=0 <=3.2.12) Commands are suggestions: review each one before running it.
Loading voting…