socket.io allows an unbounded number of binary attachments
CVE-2026-33151GHSA-677m-j7p3-52f9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (socket.io-parser 4.2.6, 3.4.4, 3.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm socket.io-parser
- Affected
- < 3.3.5>= 3.4.0, < 3.4.4>= 4.0.0, < 4.2.6
- Fixed in
- 3.4.4, 4.2.6, 3.3.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-677m-j7p3-52f9 lists affected ranges: npm socket.io-parser >=0 =3.4.0 =4.0.0 <4.2.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-677m-j7p3-52f9 lists affected ranges: npm socket.io-parser >=0 =3.4.0 =4.0.0 <4.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-33151: 0.52% estimated exploitation activity in the next 30 days; percentile 44.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory. Patches | Version range | Used by | Fixed version | |------------------|--------------------------------------------|---------------| | =4.0.0 <4.2.6 | socket.io@4.x and socket.io-client@4.x | 4.2.6 | | =3.4.0 <3.4.4 | socket.io@2.x | 3.4.4 | | <3.3.5 | socket.io-client@2.x | 3.3.5 | Workarounds There is no known workaround except upgrading to a safe version. For more information If you have any questions or comments about this advisory: - Open a discussion here
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-677m-j7p3-52f9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-677m-j7p3-52f9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33151 Advisory: socket.io allows an unbounded number of binary attachments IDs: CVE-2026-33151, GHSA-677m-j7p3-52f9 Record: https://patchnext.com/advisories/cve-2026-33151 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: socket.io-parser 4.2.6, 3.4.4, 3.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm socket.io-parser: affected < 3.3.5; >= 3.4.0, < 3.4.4; >= 4.0.0, < 4.2.6; fixed in 3.4.4, 4.2.6, 3.3.5 ## Suggested inspection (read-only) - `npm ls socket.io-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on socket.io-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-677m-j7p3-52f9 (OSV record GHSA-677m-j7p3-52f9 lists affected ranges: npm socket.io-parser >=0 =3.4.0 =4.0.0 <4.2.6 (fixed)) - Verified: https://github.com/advisories/GHSA-677m-j7p3-52f9 (GitHub-reviewed advisory GHSA-677m-j7p3-52f9 lists affected ranges: npm socket.io-parser >=0 =3.4.0 =4.0.0 <4.2.6) Commands are suggestions: review each one before running it.
Loading voting…