Skip to content

← Actionable
Medium, CVSS 5.3amended

Stored XSS in PySpector HTML Report Generation leads to Javascript Code Execution

CVE-2026-33140GHSA-2gmv-2r3v-jxj2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyspector 0.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-33140: 0.23% estimated exploitation activity in the next 30 days; percentile 13.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PySpector versions <= 0.1.6 are affected by a stored Cross-Site Scripting (XSS) vulnerability in the HTML report generator. When PySpector scans a Python file containing JavaScript payloads (i.e. inside a string passed to eval() ), the flagged code snippet is interpolated into the HTML report without sanitization. Opening the generated report in a browser causes the embedded JavaScript to execute in the browser's local file context. Impact An attacker can craft a malicious Python file (for example, hosted in a public repository), designed to be scanned by PySpector. When a victim scans this file and opens the resulting HTML report, arbitrary JavaScript executes in their browser. While the file:// context limits the attacker's ability to exfiltrate cookies or make credentialed requests, the following is still achievable: - Arbitrary DOM manipulation - Redirects to attacker-controlled pages - Theft of locally accessible data via fetch() or XMLHttpRequest to file:// paths…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2gmv-2r3v-jxj2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2gmv-2r3v-jxj2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33140

Advisory: Stored XSS in PySpector HTML Report Generation leads to Javascript Code Execution
IDs: CVE-2026-33140, GHSA-2gmv-2r3v-jxj2
Record: https://patchnext.com/advisories/cve-2026-33140 (revision 3, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyspector 0.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyspector: affected <= 0.1.6; fixed in 0.1.7

## Suggested inspection (read-only)
- `python -m pip show pyspector`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyspector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2gmv-2r3v-jxj2 (OSV record GHSA-2gmv-2r3v-jxj2 lists affected ranges: PyPI pyspector >=0 <0.1.7 (fixed))
- Verified: https://github.com/advisories/GHSA-2gmv-2r3v-jxj2 (GitHub-reviewed advisory GHSA-2gmv-2r3v-jxj2 lists affected ranges: PyPI pyspector >=0 <=0.1.6)

Commands are suggestions: review each one before running it.

Loading voting…