Skip to content

← Actionable
High, CVSS 8.3amended

PySpector has a Plugin Sandbox Bypass leads to Arbitrary Code Execution

CVE-2026-33139GHSA-v3xv-8vc3-h2m6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyspector 0.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33139: 0.17% estimated exploitation activity in the next 30 days; percentile 6.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PySpector versions <= 0.1.6 are affected by a security validation bypass in the plugin system. The validateplugincode() function in pluginsystem.py, performs static AST analysis to block dangerous API calls before a plugin is trusted and executed. However, the internal resolvename() helper only handles ast.Name and ast.Attribute node types, returning None for all others. When a plugin uses indirect function calls via getattr() (such as getattr(os, 'system')) the outer call's func node is of type ast.Call, causing resolvename() to return None, and the security check to be silently skipped. The plugin incorrectly passes the trust workflow, and executes arbitrary system commands on the user's machine when loaded. Impact An attacker who can deliver a malicious plugin file to a PySpector user and convince them to install it, can achieve arbitrary code execution on the user's local machine. Exploitation requires the victim to explicitly run pyspector plugin install --trust on the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v3xv-8vc3-h2m6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-v3xv-8vc3-h2m6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33139

Advisory: PySpector has a Plugin Sandbox Bypass leads to Arbitrary Code Execution
IDs: CVE-2026-33139, GHSA-v3xv-8vc3-h2m6
Record: https://patchnext.com/advisories/cve-2026-33139 (revision 3, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyspector 0.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyspector: affected <= 0.1.6; fixed in 0.1.7

## Suggested inspection (read-only)
- `python -m pip show pyspector`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyspector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v3xv-8vc3-h2m6 (OSV record GHSA-v3xv-8vc3-h2m6 lists affected ranges: PyPI pyspector >=0 <0.1.7 (fixed))
- Verified: https://github.com/advisories/GHSA-v3xv-8vc3-h2m6 (GitHub-reviewed advisory GHSA-v3xv-8vc3-h2m6 lists affected ranges: PyPI pyspector >=0 <=0.1.6)

Commands are suggestions: review each one before running it.

Loading voting…