Skip to content

← Actionable
High, CVSS 7.5amended

h3 has a Server-Sent Events Injection via Unsanitized Newlines in Event Stream Fields

CVE-2026-33128GHSA-22cc-p3c6-wpvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (h3 2.0.1-rc.15, 1.15.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm h3

    Affected
    >= 2.0.0, <= 2.0.1-rc.14< 1.15.6
    Fixed in
    2.0.1-rc.15, 1.15.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
EPSS
  • CVE-2026-33128: 0.58% estimated exploitation activity in the next 30 days; percentile 47.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary createEventStream in h3 is vulnerable to Server-Sent Events (SSE) injection due to missing newline sanitization in formatEventStreamMessage() and formatEventStreamComment(). An attacker who controls any part of an SSE message field (id, event, data, or comment) can inject arbitrary SSE events to connected clients. Details The vulnerability exists in src/utils/internal/event-stream.ts, lines 170-187: The SSE protocol (defined in the WHATWG HTML spec) uses newline characters (\n) as field delimiters and double newlines (\n\n) as event separators. None of the fields (id, event, data, comment) are sanitized for newline characters before being interpolated into the SSE wire format. If any field value contains \n, the SSE framing is broken, allowing an attacker to: 1. Inject arbitrary SSE fields — break out of one field and add event:, data:, id:, or retry: directives 2. Inject entirely new SSE events — using \n\n to terminate the current event and start a new one 3. Manipulate…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-22cc-p3c6-wpvm

  2. Revision 1 · created ·

    Published from osv record GHSA-22cc-p3c6-wpvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33128

Advisory: h3 has a Server-Sent Events Injection via Unsanitized Newlines in Event Stream Fields
IDs: CVE-2026-33128, GHSA-22cc-p3c6-wpvm
Record: https://patchnext.com/advisories/cve-2026-33128 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: h3 2.0.1-rc.15, 1.15.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm h3: affected >= 2.0.0, <= 2.0.1-rc.14; < 1.15.6; fixed in 2.0.1-rc.15, 1.15.6

## Suggested inspection (read-only)
- `npm ls h3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on h3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-22cc-p3c6-wpvm (OSV record GHSA-22cc-p3c6-wpvm lists affected ranges: npm h3 >=2.0.0 =0 <1.15.6 (fixed))
- Verified: https://github.com/advisories/GHSA-22cc-p3c6-wpvm (GitHub-reviewed advisory GHSA-22cc-p3c6-wpvm lists affected ranges: npm h3 >=2.0.0 =0 <1.15.6)

Commands are suggestions: review each one before running it.

Loading voting…