Filament Unvalidated Range and Values summarizer values can be used for XSS
CVE-2026-33080GHSA-vv3x-j2x5-36jc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (filament/tables 5.3.5, 4.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist filament/tables
- Affected
- >= 4.0.0, < 4.8.5>= 5.0.0, < 5.3.5
- Fixed in
- 4.8.5, 5.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vv3x-j2x5-36jc lists affected ranges: Packagist filament/tables >=4.0.0 =5.0.0 <5.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-33080: 0.30% estimated exploitation activity in the next 30 days; percentile 22.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Two Table summarizers (Range, Values) render raw database values without escaping HTML. If there is a lack of validation for the data in the columns that use these summarizers, an attacker could plant malicious HTML / JavaScript and achieve stored XSS that executes for users who view the table with those summarizers.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vv3x-j2x5-36jc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33080 Advisory: Filament Unvalidated Range and Values summarizer values can be used for XSS IDs: CVE-2026-33080, GHSA-vv3x-j2x5-36jc Record: https://patchnext.com/advisories/cve-2026-33080 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: filament/tables 5.3.5, 4.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist filament/tables: affected >= 4.0.0, < 4.8.5; >= 5.0.0, < 5.3.5; fixed in 4.8.5, 5.3.5 ## Suggested inspection (read-only) - Packagist filament/tables: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on filament/tables. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vv3x-j2x5-36jc (GitHub-reviewed advisory GHSA-vv3x-j2x5-36jc lists affected ranges: Packagist filament/tables >=4.0.0 =5.0.0 <5.3.5) Commands are suggestions: review each one before running it.
Loading voting…