Skip to content

← Actionable
High, CVSS 8.7amended

Mistune has a ReDoS in LINK_TITLE_RE that allows denial of service via crafted Markdown input

CVE-2026-33079GHSA-8mp2-v27r-99xp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mistune 3.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mistune

    Affected
    >= 3.0.0a1, <= 3.2.0
    Fixed in
    3.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33079: 0.59% estimated exploitation activity in the next 30 days; percentile 48.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A ReDoS (Regular Expression Denial of Service) vulnerability in LINKTITLERE allows an attacker who can supply Markdown for parsing to cause denial of service. A crafted 58-byte Markdown document blocks the parser for approximately 6 seconds (measured on Apple M2, Python 3.14.3), with exponential growth per additional byte pair. Details The vulnerable regex is defined in src/mistune/helpers.py#L20-L25: The double-quote branch compiles to "(?:\\[PUNCTUATION]|[^"\x00])". The two alternatives inside (A|B) overlap: a backslash followed by a punctuation character (e.g. \!) can be matched by either branch — as a 2-character escaped-punctuation sequence \\!, or as two individual [^"\x00] characters (\ then !). The same ambiguity exists in the single-quoted title branch. When the input contains repeated \! pairs with no closing ", the regex engine exhaustively backtracks through all 2^N combinations, resulting in exponential O(2^N) time complexity. This is reachable through normal…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8mp2-v27r-99xp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8mp2-v27r-99xp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33079

Advisory: Mistune has a ReDoS in LINK_TITLE_RE that allows denial of service via crafted Markdown input
IDs: CVE-2026-33079, GHSA-8mp2-v27r-99xp
Record: https://patchnext.com/advisories/cve-2026-33079 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mistune 3.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mistune: affected >= 3.0.0a1, <= 3.2.0; fixed in 3.2.1

## Suggested inspection (read-only)
- `python -m pip show mistune`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mistune.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8mp2-v27r-99xp (OSV record GHSA-8mp2-v27r-99xp lists affected ranges: PyPI mistune >=3.0.0a1 <3.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-8mp2-v27r-99xp (GitHub-reviewed advisory GHSA-8mp2-v27r-99xp lists affected ranges: PyPI mistune >=3.0.0a1 <=3.2.0)

Commands are suggestions: review each one before running it.

Loading voting…