Home Assistant has stored XSS in history-graphs
CVE-2026-33045GHSA-46j8-vpx8-6p72
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (homeassistant 2026.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI homeassistant
- Affected
- >= 2025.2, < 2026.1
- Fixed in
- 2026.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-46j8-vpx8-6p72 lists affected ranges: PyPI homeassistant >=2025.02 <2026.01 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-46j8-vpx8-6p72 lists affected ranges: PyPI homeassistant >=2025.2 <2026.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-33045: 0.21% estimated exploitation activity in the next 30 days; percentile 11.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The "remaining charge time"-sensor for mobile phones (imported/included from Android Auto it appears) is vulnerable to the same issue as CVE-2025-62172. <img width="431" height="334" alt="image" src="https://github.com/user-attachments/assets/84e0dfad-b986-4e84-ad0e-674c5da88582" / This also indicates that any sensor showing their name in the history-graph, is likely to be vulnerable to this issue. Details Another entity was found which displays the same behavior as in this issue: CVE-2025-62172 The History-graph card will sometimes display the name of the entity it is displaying, when the graph is shown as a line with values on the x and y axis. This appears to be vulnerable to Cross-Site scripting (XSS) as it does not have any output escaping or sanitization. The PoC in this instance only shows HTML-injection in the form of the <s -tag being rendered as strike through, but the vulnerability also allows for injecting arbitrary tags which execute JavaScript, like the example…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-46j8-vpx8-6p72
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-46j8-vpx8-6p72
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33045 Advisory: Home Assistant has stored XSS in history-graphs IDs: CVE-2026-33045, GHSA-46j8-vpx8-6p72 Record: https://patchnext.com/advisories/cve-2026-33045 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: homeassistant 2026.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI homeassistant: affected >= 2025.2, < 2026.1; fixed in 2026.1 ## Suggested inspection (read-only) - `python -m pip show homeassistant`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on homeassistant. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-46j8-vpx8-6p72 (OSV record GHSA-46j8-vpx8-6p72 lists affected ranges: PyPI homeassistant >=2025.02 <2026.01 (fixed)) - Verified: https://github.com/advisories/GHSA-46j8-vpx8-6p72 (GitHub-reviewed advisory GHSA-46j8-vpx8-6p72 lists affected ranges: PyPI homeassistant >=2025.2 <2026.1) Commands are suggestions: review each one before running it.
Loading voting…