Skip to content

← Actionable
High, CVSS 7.5amended

fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278)

CVE-2026-33036GHSA-8gc5-j5rx-235r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-xml-parser 5.5.6, 4.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-xml-parser

    Affected
    >= 5.0.0, < 5.5.6>= 4.0.0-beta.3, < 4.5.5
    Fixed in
    5.5.6, 4.5.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-33036: 0.60% estimated exploitation activity in the next 30 days; percentile 48.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The fix for CVE-2026-26278 added entity expansion limits (maxTotalExpansions, maxExpandedLength, maxEntityCount, maxEntitySize) to prevent XML entity expansion Denial of Service. However, these limits are only enforced for DOCTYPE-defined entities. Numeric character references (&#NNN; and &#xHH;) and standard XML entities (&lt;, &gt;, etc.) are processed through a separate code path that does NOT enforce any expansion limits. An attacker can use massive numbers of numeric entity references to completely bypass all configured limits, causing excessive memory allocation and CPU consumption. Affected Versions fast-xml-parser v5.x through v5.5.3 (and likely v5.5.5 on npm) Root Cause In src/xmlparser/OrderedObjParser.js, the replaceEntitiesValue() function has two separate entity replacement loops: 1. Lines 638-670: DOCTYPE entities — expansion counting with entityExpansionCount and currentExpandedLength tracking. This was the CVE-2026-26278 fix. 2. Lines 674-677: lastEntities…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8gc5-j5rx-235r

  2. Revision 1 · created ·

    Published from osv record GHSA-8gc5-j5rx-235r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33036

Advisory: fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278)
IDs: CVE-2026-33036, GHSA-8gc5-j5rx-235r
Record: https://patchnext.com/advisories/cve-2026-33036 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-xml-parser 5.5.6, 4.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-xml-parser: affected >= 5.0.0, < 5.5.6; >= 4.0.0-beta.3, < 4.5.5; fixed in 5.5.6, 4.5.5

## Suggested inspection (read-only)
- `npm ls fast-xml-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-xml-parser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8gc5-j5rx-235r (OSV record GHSA-8gc5-j5rx-235r lists affected ranges: npm fast-xml-parser >=5.0.0 =4.0.0-beta.3 <4.5.5 (fixed))
- Verified: https://github.com/advisories/GHSA-8gc5-j5rx-235r (GitHub-reviewed advisory GHSA-8gc5-j5rx-235r lists affected ranges: npm fast-xml-parser >=5.0.0 =4.0.0-beta.3 <4.5.5)

Commands are suggestions: review each one before running it.

Loading voting…