Nginx-UI: Disabled users retain full API access through previously issued bearer tokens
CVE-2026-33031GHSA-x234-x5vq-cc2v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/Nginx-UI 1.9.10-0.20260314152518-7b66578adb47), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/0xJacky/Nginx-UI
- Affected
- < 1.9.10-0.20260314152518-7b66578adb47
- Fixed in
- 1.9.10-0.20260314152518-7b66578adb47
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x234-x5vq-cc2v lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260314152518-7b66578adb47
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-33031: 0.27% estimated exploitation activity in the next 30 days; percentile 19.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A user who was disabled by an administrator can use previously issued API tokens for up to the token lifetime. In practice, disabling a compromised account does not actually terminate that user’s access, so an attacker who already stole a JWT can continue reading and modifying protected resources after the account is marked disabled. Since tokens can be used to create new accounts, it is possible the disabled user to maintain the privilege. Details The application exposes an account-level disable control through the users management API. Login process correctly enforces that control: https://github.com/0xJacky/nginx-ui/blob/6ec542fd97abf2c5950f374f78a32938ad0030e6/internal/user/login.go#L29-L31 However, token-based authentication does not enforce the same check (This code validates token structure and expiry, but returns that user object without checking user.Status.):…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x234-x5vq-cc2v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33031 Advisory: Nginx-UI: Disabled users retain full API access through previously issued bearer tokens IDs: CVE-2026-33031, GHSA-x234-x5vq-cc2v Record: https://patchnext.com/advisories/cve-2026-33031 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/Nginx-UI 1.9.10-0.20260314152518-7b66578adb47. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/0xJacky/Nginx-UI: affected < 1.9.10-0.20260314152518-7b66578adb47; fixed in 1.9.10-0.20260314152518-7b66578adb47 ## Suggested inspection (read-only) - Go github.com/0xJacky/Nginx-UI: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/0xJacky/Nginx-UI. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x234-x5vq-cc2v (GitHub-reviewed advisory GHSA-x234-x5vq-cc2v lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260314152518-7b66578adb47) Commands are suggestions: review each one before running it.
Loading voting…