Skip to content

← Actionable
Critical, CVSS 9.3Exploited · CISA KEVamended

Unauthenticated Remote Code Execution in Langflow via Public Flow Build Endpoint

CVE-2026-33017GHSA-vwmf-pq79-vjvx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langflow

    Affected
    <= 1.8.2
    Fixed in
    1.9.0

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/E:A · score source
EPSS
  • CVE-2026-33017: 96.18% estimated exploitation activity in the next 30 days; percentile 99.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The POST /api/v1/buildpublictmp/{flowid}/flow endpoint allows building public flows without requiring authentication. When the optional data parameter is supplied, the endpoint uses attacker-controlled flow data (containing arbitrary Python code in node definitions) instead of the stored flow data from the database. This code is passed to exec() with zero sandboxing, resulting in unauthenticated remote code execution. This is distinct from CVE-2025-3248, which fixed /api/v1/validate/code by adding authentication. The buildpublictmp endpoint is designed to be unauthenticated (for public flows) but incorrectly accepts attacker-supplied flow data containing arbitrary executable code. Affected Code Vulnerable Endpoint (No Authentication) File: src/backend/base/langflow/api/v1/chat.py, lines 580-657 Compare with the authenticated build endpoint at line 138, which requires currentuser: CurrentActiveUser. Code Execution Chain When attacker-supplied data is provided, it flows…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-vwmf-pq79-vjvx

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-vwmf-pq79-vjvx

  4. Revision 1 · created ·

    Published from ghsa record GHSA-vwmf-pq79-vjvx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33017

Advisory: Unauthenticated Remote Code Execution in Langflow via Public Flow Build Endpoint
IDs: CVE-2026-33017, GHSA-vwmf-pq79-vjvx
Record: https://patchnext.com/advisories/cve-2026-33017 (revision 4, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: langflow 1.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow: affected <= 1.8.2; fixed in 1.9.0

## Suggested inspection (read-only)
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vwmf-pq79-vjvx (GitHub-reviewed advisory GHSA-vwmf-pq79-vjvx lists affected ranges: PyPI langflow >=0 <=1.8.2)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2026-33017 to the Known Exploited Vulnerabilities catalog on 2026-03-25.)
- Verified: https://osv.dev/vulnerability/GHSA-vwmf-pq79-vjvx (OSV record GHSA-vwmf-pq79-vjvx lists affected ranges: PyPI langflow >=0 <1.9.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…