Skip to content

← Actionable
High, CVSS 8.0amended

OpenClaw: Unrecognized script runners could bypass system.run approval integrity

CVE-2026-32978GHSA-qc36-x95h-7j53

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.3.11
    Fixed in
    2026.3.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-32978: 0.18% estimated exploitation activity in the next 30 days; percentile 7.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions of openclaw, node-host system.run approvals did not bind a mutable file operand for some script runners, including forms such as tsx and jiti. An attacker could obtain approval for a benign script-runner command, rewrite the referenced script on disk, and have the modified code execute under the already approved run context. Impact Deployments that rely on node-host system.run approvals for script integrity could execute rewritten local code after operator approval. This can lead to unintended local code execution as the OpenClaw runtime user. Affected Packages and Versions - Package: openclaw (npm) - Affected versions: < 2026.3.11 - Fixed in: 2026.3.11 Technical Details The approval planner only tracked mutable script operands for a hardcoded set of interpreters and runtime forms. Commands such as tsx ./run.ts and jiti ./run.ts fell through without a bound file snapshot, so the final pre-execution revalidation step was skipped. Fix OpenClaw now fails…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qc36-x95h-7j53

  2. Revision 1 · created ·

    Published from osv record GHSA-qc36-x95h-7j53

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32978

Advisory: OpenClaw: Unrecognized script runners could bypass `system.run` approval integrity
IDs: CVE-2026-32978, GHSA-qc36-x95h-7j53
Record: https://patchnext.com/advisories/cve-2026-32978 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.3.11; fixed in 2026.3.11

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qc36-x95h-7j53 (OSV record GHSA-qc36-x95h-7j53 lists affected ranges: npm openclaw >=0 <2026.3.11 (fixed))
- Verified: https://github.com/advisories/GHSA-qc36-x95h-7j53 (GitHub-reviewed advisory GHSA-qc36-x95h-7j53 lists affected ranges: npm openclaw >=0 <2026.3.11)

Commands are suggestions: review each one before running it.

Loading voting…