Skip to content

← Actionable
Medium, CVSS 6.5amended

OpenClaw: Channel commands could bypass account-scoped configWrites restrictions

CVE-2026-32976GHSA-8jhh-jcqg-mj5p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.3.11
    Fixed in
    2026.3.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-32976: 0.20% estimated exploitation activity in the next 30 days; percentile 9.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions of openclaw, channel-initiated config mutations were authorized against the originating account's configWrites policy but did not consistently re-check the targeted account scope. An authorized sender on one account could mutate protected sibling-account configuration when the target account had configWrites: false. Impact This is an account-scoped policy bypass inside a single gateway deployment. Channel commands such as /config set channels.<provider.accounts.<id... and config-backed /allowlist ... --config --account <id could modify protected sibling-account configuration. Affected Packages and Versions - Package: openclaw (npm) - Affected versions: <= 2026.3.8 - Fixed in: 2026.3.11 Technical Details The mutation path validated the origin account scope but did not consistently authorize every resolved target scope. Ambiguous collection and root writes under channels and channels.<provider.accounts could therefore reach protected account configuration…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8jhh-jcqg-mj5p

  2. Revision 1 · created ·

    Published from osv record GHSA-8jhh-jcqg-mj5p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32976

Advisory: OpenClaw: Channel commands could bypass account-scoped `configWrites` restrictions
IDs: CVE-2026-32976, GHSA-8jhh-jcqg-mj5p
Record: https://patchnext.com/advisories/cve-2026-32976 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.3.11; fixed in 2026.3.11

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8jhh-jcqg-mj5p (OSV record GHSA-8jhh-jcqg-mj5p lists affected ranges: npm openclaw >=0 <2026.3.11 (fixed))
- Verified: https://github.com/advisories/GHSA-8jhh-jcqg-mj5p (GitHub-reviewed advisory GHSA-8jhh-jcqg-mj5p lists affected ranges: npm openclaw >=0 <2026.3.11)

Commands are suggestions: review each one before running it.

Loading voting…