OpenClaw's Zalouser allowlist authorization matched mutable group names by default
CVE-2026-32975GHSA-f5mf-3r52-r83w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.3.11
- Fixed in
- 2026.3.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f5mf-3r52-r83w lists affected ranges: npm openclaw >=0 <2026.3.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f5mf-3r52-r83w lists affected ranges: npm openclaw >=0 <=2026.3.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-32975: 0.34% estimated exploitation activity in the next 30 days; percentile 27.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary OpenClaw's Zalouser allowlist mode accepted mutable group names and normalized slugs as authorization matches instead of requiring stable group IDs. In deployments that used name-based channels.zalouser.groups entries together with permissive sender allowlists, a different group could be accepted by reusing the same display name as an allowlisted group. Impact This weakened channel authorization for Zalouser group routing and could allow messages from an unintended group to reach the agent when operators relied on group names instead of stable IDs. Affected versions openclaw <= 2026.3.11 Patch Fixed in openclaw 2026.3.12. Allowlist authorization now matches stable group identifiers, and users should update to 2026.3.12 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f5mf-3r52-r83w
- Revision 1 · created ·
Published from osv record GHSA-f5mf-3r52-r83w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32975 Advisory: OpenClaw's Zalouser allowlist authorization matched mutable group names by default IDs: CVE-2026-32975, GHSA-f5mf-3r52-r83w Record: https://patchnext.com/advisories/cve-2026-32975 (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.12. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.3.11; fixed in 2026.3.12 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f5mf-3r52-r83w (OSV record GHSA-f5mf-3r52-r83w lists affected ranges: npm openclaw >=0 <2026.3.12 (fixed)) - Verified: https://github.com/advisories/GHSA-f5mf-3r52-r83w (GitHub-reviewed advisory GHSA-f5mf-3r52-r83w lists affected ranges: npm openclaw >=0 <=2026.3.11) Commands are suggestions: review each one before running it.
Loading voting…