Skip to content

← Actionable
Low, CVSS 2.5amended

OpenClaw: Unavailable local auth SecretRefs could fall through to remote credentials in local mode

CVE-2026-32970GHSA-qvr7-g57c-mrc7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.3.11
    Fixed in
    2026.3.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.5 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-32970: 0.11% estimated exploitation activity in the next 30 days; percentile 1.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions of openclaw, local gateway helper credential resolution treated configured but unavailable gateway.auth.token and gateway.auth.password SecretRefs as if they were unset and could fall back to gateway.remote. credentials in local mode. Impact This could cause local CLI and helper paths to select the wrong credential source instead of failing closed for configured local auth SecretRefs. We did not confirm a server-side gateway-authentication boundary bypass for this issue. Affected Packages and Versions - Package: openclaw (npm) - Affected versions: <= 2026.3.8 - Fixed in: 2026.3.11 Technical Details The local-mode fallback logic decided whether remote credential fallback was allowed based on resolved credential values rather than on whether the local auth input was actually configured. A configured-but-unavailable local SecretRef therefore looked "absent" to the helper layer. Fix OpenClaw now tracks whether the local auth input is configured separately…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qvr7-g57c-mrc7

  2. Revision 1 · created ·

    Published from osv record GHSA-qvr7-g57c-mrc7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32970

Advisory: OpenClaw: Unavailable local auth SecretRefs could fall through to remote credentials in local mode
IDs: CVE-2026-32970, GHSA-qvr7-g57c-mrc7
Record: https://patchnext.com/advisories/cve-2026-32970 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.3.11; fixed in 2026.3.11

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qvr7-g57c-mrc7 (OSV record GHSA-qvr7-g57c-mrc7 lists affected ranges: npm openclaw >=0 <2026.3.11 (fixed))
- Verified: https://github.com/advisories/GHSA-qvr7-g57c-mrc7 (GitHub-reviewed advisory GHSA-qvr7-g57c-mrc7 lists affected ranges: npm openclaw >=0 <2026.3.11)

Commands are suggestions: review each one before running it.

Loading voting…