Parse Server has a password reset token single-use bypass via concurrent requests
CVE-2026-32943GHSA-r3xq-68wh-gwvh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.28, 8.6.48), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.6.0-alpha.28< 8.6.48
- Fixed in
- 8.6.48, 9.6.0-alpha.28
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r3xq-68wh-gwvh lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.48 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r3xq-68wh-gwvh lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.48
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32943: 0.21% estimated exploitation activity in the next 30 days; percentile 12.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The password reset mechanism does not enforce single-use guarantees for reset tokens. When a user requests a password reset, the generated token can be consumed by multiple concurrent requests within a short time window. An attacker who has intercepted a password reset token can race the legitimate user's password reset request, causing both requests to succeed. This may result in the legitimate user believing their password was changed successfully while the attacker's password takes effect instead. All Parse Server deployments that use the password reset feature are affected. Patches The password reset token is now atomically validated and consumed as part of the password update operation. The database query that updates the password includes the reset token as a condition, ensuring that only one concurrent request can successfully consume the token. Subsequent requests using the same token will fail because the token has already been cleared. Workarounds There is no known…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r3xq-68wh-gwvh
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-r3xq-68wh-gwvh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32943 Advisory: Parse Server has a password reset token single-use bypass via concurrent requests IDs: CVE-2026-32943, GHSA-r3xq-68wh-gwvh Record: https://patchnext.com/advisories/cve-2026-32943 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.28, 8.6.48. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.28; < 8.6.48; fixed in 8.6.48, 9.6.0-alpha.28 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r3xq-68wh-gwvh (OSV record GHSA-r3xq-68wh-gwvh lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.48 (fixed)) - Verified: https://github.com/advisories/GHSA-r3xq-68wh-gwvh (GitHub-reviewed advisory GHSA-r3xq-68wh-gwvh lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.48) Commands are suggestions: review each one before running it.
Loading voting…