Skip to content

← Actionable
High, CVSS 8.2

phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack

CVE-2026-32935GHSA-94g3-g5v7-q4jg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpseclib/phpseclib 3.0.50, 2.0.52, 1.0.27), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpseclib/phpseclib

    Affected
    >= 3.0.0, <= 3.0.49>= 2.0.0, <= 2.0.51>= 0.1.1, <= 1.0.26
    Fixed in
    1.0.27, 3.0.50, 2.0.52

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32935: 0.39% estimated exploitation activity in the next 30 days; percentile 33.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Those using AES in CBC mode may be susceptible to a padding oracle timing attack. Patches https://github.com/phpseclib/phpseclib/commit/ccc21aef71eb170e9bf819b167e67d1fd9e6e788 Workarounds Use AES in CTR, CFB or OFB modes References https://github.com/phpseclib/phpseclib/commit/ccc21aef71eb170e9bf819b167e67d1fd9e6e788

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-94g3-g5v7-q4jg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32935

Advisory: phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack
IDs: CVE-2026-32935, GHSA-94g3-g5v7-q4jg
Record: https://patchnext.com/advisories/cve-2026-32935 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpseclib/phpseclib 3.0.50, 2.0.52, 1.0.27. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpseclib/phpseclib: affected >= 3.0.0, <= 3.0.49; >= 2.0.0, <= 2.0.51; >= 0.1.1, <= 1.0.26; fixed in 1.0.27, 3.0.50, 2.0.52

## Suggested inspection (read-only)
- Packagist phpseclib/phpseclib: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpseclib/phpseclib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-94g3-g5v7-q4jg (GitHub-reviewed advisory GHSA-94g3-g5v7-q4jg lists affected ranges: Packagist phpseclib/phpseclib >=3.0.0 =2.0.0 =0.1.1 <=1.0.26)

Commands are suggestions: review each one before running it.

Loading voting…