Skip to content

← Actionable
High, CVSS 7.5

AutoMapper Vulnerable to Denial of Service (DoS) via Uncontrolled Recursion

CVE-2026-32933GHSA-rvv3-g6hj-g44x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (automapper 16.1.1, 15.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet automapper

    Affected
    >= 16.0.0, < 16.1.1< 15.1.1
    Fixed in
    15.1.1, 16.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-32933: 0.55% estimated exploitation activity in the next 30 days; percentile 46.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary AutoMapper is vulnerable to a Denial of Service (DoS) attack. When mapping deeply nested object graphs, the library uses recursive method calls without enforcing a default maximum depth limit. This allows an attacker to provide a specially crafted object graph that exhausts the thread's stack memory, triggering a StackOverflowException and causing the entire application process to terminate. Description The vulnerability exists in the core mapping engine. When a source object contains a property of the same type (or a type that eventually points back to itself), AutoMapper recursively attempts to map each level. Because there is no default limit on how many levels deep this recursion can go, a sufficiently nested object (approximately 25,000+ levels in standard .NET environments) will exceed the stack size. Since StackOverflowException cannot be caught in modern .NET runtimes, the application cannot recover and will crash immediately. Impact Availability: An attacker can…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rvv3-g6hj-g44x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32933

Advisory: AutoMapper Vulnerable to Denial of Service (DoS) via Uncontrolled Recursion
IDs: CVE-2026-32933, GHSA-rvv3-g6hj-g44x
Record: https://patchnext.com/advisories/cve-2026-32933 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: automapper 16.1.1, 15.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet automapper: affected >= 16.0.0, < 16.1.1; < 15.1.1; fixed in 15.1.1, 16.1.1

## Suggested inspection (read-only)
- NuGet automapper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on automapper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rvv3-g6hj-g44x (GitHub-reviewed advisory GHSA-rvv3-g6hj-g44x lists affected ranges: NuGet automapper >=16.0.0 =0 <15.1.1)

Commands are suggestions: review each one before running it.

Loading voting…