Skip to content

← Actionable
Medium, CVSS 6.3amended

OpenClaw's system.run approvals did not bind mutable script operands across approval and execution

CVE-2026-32921GHSA-8g75-q649-6pv6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.3.7
    Fixed in
    2026.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-32921: 0.20% estimated exploitation activity in the next 30 days; percentile 10.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenClaw's system.run approval flow did not bind mutable interpreter-style script operands across approval and execution. A caller could obtain approval for an execution such as sh ./script.sh, rewrite the approved script before execution, and then execute different content under the previously approved command shape. The approved argv values remained the same, but the mutable script operand content could drift after approval. Latest published npm version verified vulnerable: 2026.3.7 The initial March 7, 2026 fix in c76d29208bf6a7f058d2cf582519d28069e42240 added approval binding for shell scripts and a narrow interpreter set, but follow-up maintainer review on March 8, 2026 found that bun and deno script operands still did not produce mutableFileOperand snapshots. A complete fix shipped on March 9, 2026 in cf3a479bd1204f62eef7dd82b4aa328749ae6c91, which binds approved bun and deno run script operands to on-disk file snapshots and denies post-approval script drift before execution.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8g75-q649-6pv6

  2. Revision 1 · created ·

    Published from osv record GHSA-8g75-q649-6pv6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32921

Advisory: OpenClaw's system.run approvals did not bind mutable script operands across approval and execution
IDs: CVE-2026-32921, GHSA-8g75-q649-6pv6
Record: https://patchnext.com/advisories/cve-2026-32921 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.3.7; fixed in 2026.3.8

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8g75-q649-6pv6 (OSV record GHSA-8g75-q649-6pv6 lists affected ranges: npm openclaw >=0 <2026.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-8g75-q649-6pv6 (GitHub-reviewed advisory GHSA-8g75-q649-6pv6 lists affected ranges: npm openclaw >=0 <=2026.3.7)

Commands are suggestions: review each one before running it.

Loading voting…