OpenClaw: session_status let sandboxed subagents access parent or sibling session state
CVE-2026-32918GHSA-wcxr-59v9-rxr8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.3.8
- Fixed in
- 2026.3.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wcxr-59v9-rxr8 lists affected ranges: npm openclaw >=0 <2026.3.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wcxr-59v9-rxr8 lists affected ranges: npm openclaw >=0 <=2026.3.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-32918: 0.10% estimated exploitation activity in the next 30 days; percentile 0.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The built-in sessionstatus tool did not enforce the intended session-visibility boundary. A sandboxed subagent could supply another session's sessionKey and inspect or modify state outside its own sandbox scope. Impact This allowed a sandboxed child session to read parent or sibling session data and, in affected releases, update the target session's persisted model override. Affected versions openclaw <= 2026.3.8 Patch Fixed in openclaw 2026.3.11 and included in later releases such as 2026.3.12. Session visibility checks now enforce the sandbox boundary before reading or mutating session state.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wcxr-59v9-rxr8
- Revision 1 · created ·
Published from osv record GHSA-wcxr-59v9-rxr8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32918 Advisory: `OpenClaw: session_status` let sandboxed subagents access parent or sibling session state IDs: CVE-2026-32918, GHSA-wcxr-59v9-rxr8 Record: https://patchnext.com/advisories/cve-2026-32918 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.11. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.3.8; fixed in 2026.3.11 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wcxr-59v9-rxr8 (OSV record GHSA-wcxr-59v9-rxr8 lists affected ranges: npm openclaw >=0 <2026.3.11 (fixed)) - Verified: https://github.com/advisories/GHSA-wcxr-59v9-rxr8 (GitHub-reviewed advisory GHSA-wcxr-59v9-rxr8 lists affected ranges: npm openclaw >=0 <=2026.3.8) Commands are suggestions: review each one before running it.
Loading voting…