Skip to content

← Actionable
High, CVSS 7.2amended

OpneClaw accepts unsanitized iMessage attachment paths which allowed SCP remote-path command injection

CVE-2026-32917GHSA-g2f6-pwvx-r275

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.3.12
    Fixed in
    2026.3.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-32917: 2.01% estimated exploitation activity in the next 30 days; percentile 80.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary openclaw versions <= 2026.3.12 accepted unsanitized iMessage remote attachment paths when staging files over SCP, allowing shell metacharacters in the remote path operand. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.3.12 - Fixed version: 2026.3.13 Details The vulnerable path was the remote attachment staging flow in src/auto-reply/reply/stage-sandbox-media.ts. When ctx.MediaRemoteHost was set, OpenClaw staged the attachment by spawning /usr/bin/scp against <remoteHost:<remotePath. In affected releases, the remote host was normalized but the remote attachment path was not validated for shell metacharacters before being passed to the SCP remote operand. A sender-controlled iMessage attachment filename containing shell metacharacters could therefore trigger command execution on the configured remote host when remote attachment staging was enabled. This issue is in scope under OpenClaw's trust model because it crosses an inbound content…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g2f6-pwvx-r275

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g2f6-pwvx-r275

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32917

Advisory: OpneClaw accepts unsanitized iMessage attachment paths which allowed SCP remote-path command injection
IDs: CVE-2026-32917, GHSA-g2f6-pwvx-r275
Record: https://patchnext.com/advisories/cve-2026-32917 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.3.12; fixed in 2026.3.13

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g2f6-pwvx-r275 (OSV record GHSA-g2f6-pwvx-r275 lists affected ranges: npm openclaw >=0 <2026.3.13 (fixed))
- Verified: https://github.com/advisories/GHSA-g2f6-pwvx-r275 (GitHub-reviewed advisory GHSA-g2f6-pwvx-r275 lists affected ranges: npm openclaw >=0 <=2026.3.12)

Commands are suggestions: review each one before running it.

Loading voting…