OpenClaw: Plugin subagent routes could bypass gateway authorization with synthetic admin scopes
CVE-2026-32916GHSA-xw77-45gv-p728
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- >= 2026.3.7, < 2026.3.11
- Fixed in
- 2026.3.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xw77-45gv-p728 lists affected ranges: npm openclaw >=2026.3.7 <2026.3.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xw77-45gv-p728 lists affected ranges: npm openclaw >=2026.3.7 <2026.3.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2026-32916: 0.48% estimated exploitation activity in the next 30 days; percentile 41.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In affected versions of openclaw, the plugin subagent runtime dispatched gateway methods through a synthetic operator client that always carried broad administrative scopes. Plugin-owned HTTP routes using auth: "plugin" could therefore trigger admin-only gateway actions without normal gateway authorization. Impact This is a critical authorization bypass. An external unauthenticated request to a plugin-owned route could reach privileged subagent runtime methods and perform admin-only gateway actions such as deleting sessions, reading session data, or triggering agent execution. Affected Packages and Versions - Package: openclaw (npm) - Affected versions: = 2026.3.7, < 2026.3.11 - Fixed in: 2026.3.11 Technical Details The new plugin subagent runtime preserved neither the original caller's auth context nor least-privilege scope. Instead, it executed gateway dispatches through a fabricated operator client with administrative scopes, which was reachable from plugin-owned routes…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xw77-45gv-p728
- Revision 2 · amended ·
Amended from osv record GHSA-xw77-45gv-p728
- Revision 1 · created ·
Published from ghsa record GHSA-xw77-45gv-p728
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32916 Advisory: OpenClaw: Plugin subagent routes could bypass gateway authorization with synthetic admin scopes IDs: CVE-2026-32916, GHSA-xw77-45gv-p728 Record: https://patchnext.com/advisories/cve-2026-32916 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.11. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected >= 2026.3.7, < 2026.3.11; fixed in 2026.3.11 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xw77-45gv-p728 (GitHub-reviewed advisory GHSA-xw77-45gv-p728 lists affected ranges: npm openclaw >=2026.3.7 <2026.3.11) - Verified: https://osv.dev/vulnerability/GHSA-xw77-45gv-p728 (OSV record GHSA-xw77-45gv-p728 lists affected ranges: npm openclaw >=2026.3.7 <2026.3.11 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…